Hi,
I'm trying to get my scanner working (Canon Canoscan N670U)
with xsane-0.91, sane-backends-1.0.12_3 and sane-frontends-1.0.11
When I run scanimage -L it crashes to db

WARNING: Driver mistake: destroy_dev on 144/0
panic: don't do that
Debugger("panic")
Stopped at     Debugger+0x54:   xchgl    %ebx,in_Debugger.0
db>

Or it simply claims it didn't find any scanner (best times).

My dmesg shows the following (what's this port error?):
uhci0: <VIA 83C572 USB controller> port 0xb000-0xb01f irq 11 at device
16.0 on p
ci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhub0: port error, restarting port 1
uhub0: port error, giving up port 1
ugen0: Canon CanoScan, rev 1.10/1.00, addr 2
uhub0: port error, restarting port 2
uhub0: port error, giving up port 2
uhci1: <VIA 83C572 USB controller> port 0xb400-0xb41f irq 11 at device
16.1 on p
ci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhub1: port error, restarting port 1
uhub1: port error, giving up port 1
uhub1: port error, restarting port 2
uhub1: port error, giving up port 2
uhci2: <VIA 83C572 USB controller> port 0xb800-0xb81f irq 10 at device
16.2 on p
ci0
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhub2: port error, restarting port 1
uhub2: port error, giving up port 1
uhub2: port error, restarting port 2
uhub2: port error, giving up port 2

#:> usbdevs -v
Controller /dev/usb0:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
VIA(0x0000),
rev 1.00
 port 1 addr 2: full speed, power 500 mA, config 1, CanoScan(0x220d),
Canon(0x04
a9), rev 1.00
 port 2 powered
Controller /dev/usb1:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
VIA(0x0000),
rev 1.00
 port 1 powered
 port 2 powered
Controller /dev/usb2:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
VIA(0x0000),
rev 1.00
 port 1 powered
 port 2 powered

#:> kldstat
Id Refs Address    Size     Name
 1   11 0xc0400000 45b388   kernel
 2    2 0xc085c000 1d328    linux.ko
 3    1 0xc087a000 1af244   nvidia.ko
 4    1 0xc0a2a000 4b9a0    acpi.ko
 5    1 0xc6c77000 2000     blank_saver.ko

#:> sane-find-scanner

  # No SCSI scanners found. If you expected something different, make
  # sure that
  # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9, product=0x220d) at
libusb:/dev/usb0:/dev/ugen0

  # Your USB scanner was (probably) detected. It may or may not be
  # supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Scanners connected to the parallel port or other proprietary ports
  # can't be
  # detected by this program.

/usr/local/etc/sane.d/plustek.conf:
[usb] 0x04a9 0x220d
option lampOff 300
option warmup 15
option lOffOnEnd 1
option posOffX 0
option posOffY 0
option tpaOffX 0
option tpaOffY 0
option negOffX 0
option negOffY 0
option posShadingY -1
option tpaShadingY -1
option negShadingY -1
option invertNegatives 0
option skipCalibration 0
option skipFine 0
option skipFineWhite 0
option red_gain   -1
option green_gain -1
option blue_gain  -1
option redGamma         1.0
option greenGamma       1.0
option blueGamma        1.0
option grayGamma        1.0
option enableTPA 0
#device libusb:/dev/usb0:/dev/ugen0
#device libusb:001:001
#device /dev/usbscanner0
device auto

-- 
> Enfin vivement les procs optique qui ne chaufferont pas trop ;-)
Vivement les proc quantiques, en rajoutant un glaçon, on pourra même 
les boire ...
[ Eric Dillenseger GPG(OxFF352913) eric(at)naxalite(dot)ath(dot)cx ]

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to