Wes Zuber wrote:

Are you sure that you have a kernel at /tmp ? Your config says that the root "/" for this boot is really at /tmp


--Wes



Yes, I've placed a stripped and gzipped kernel in both /tmp and, just to be on the safe side, in the /tftpboot directory as well. It seems to me that it loads the kernel ok, but I'm not sure what it gets stuck on. Fyi, I did make sure that md0 exists in /dev, and the diskless /etc exists in both /tmp/etc and /tmp/conf/base/etc. Here is a more complete dmesg. Please excuse the verbosity :)


Building the boot loader arguments
Relocating the loader and the BTX
Starting the BTX loader
Console: internal video/keyboard

PXE version 2.1, real mode entry point @9e79:0106
BIOS 577kB/64512kB available memory

FreeBSD/i386 bootstrap loader, Revision 0.8
([EMAIL PROTECTED], Mon Oct 13 17:25:56 CDT 2003)
pxe_open: server addr: 172.16.34.1
pxe_open: server path: /tmp
pxe_open: gateway ip: 172.16.34.1
Loading /boot/defaults/loader.conf
/kernel text=0x1b91dd data=0x20a74+0x1f598 -
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 4.9-RC #0: Mon Oct 13 17:30:48 CDT 2003
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/DISKLESS
Calibrating clock(s) ... i8254 clock: 1189161 Hz
Timecounter "i8254" frequency 1189161 Hz
CPU: AMD Enhanced Am486DX4/Am5x86 Write-Back (486-class CPU)
Origin = "AuthenticAMD" Id = 0x494 Stepping = 4
Features=0x1<FPU>
real memory = 67108864 (65536K bytes)
Physical memory chunk(s):
0x000001000 - 0x00008ffff, 585728 bytes (143 pages)
0x000323000 - 0x003ff7fff, 63787008 bytes (15573 pages)
avail memory = 62291968 (60832K bytes)
bios32: Found BIOS32 Service Directory header at 0xc00f0080
bios32: Entry = 0xf00c0 (c00f00c0) Rev = 0 Len = 1
pcibios: PCI BIOS entry at 0xe1
Other BIOS signatures found:
ACPI: 00000000
Preloaded elf kernel "kernel" at 0xc02fc000.
crypto: <crypto core>
Creating DISK md0
md0: Malloc disk
pci_open(1): mode 1 addr port (0x0cf8) is 0x00000000
pci_open(1a): mode1res=0x80000000 (0x80000000)
pci_cfgcheck: device 0 [class=060000] [hdr=00] is there (id=30001022)
Doing h0h0magic for AMD Elan sc520
sysctl machdep.i8254_freq=1189161 returns 0
Timecounter "ELAN" frequency 8333333 Hz
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <AMD Elan SC520 host to PCI bridge> on motherboard
found-> vendor=0x1022, dev=0x3000, revid=0x00
class=06-00-00, hdrtype=0x00, mfdev=0
subordinatebus=0 secondarybus=0
found-> vendor=0x100b, dev=0x0020, revid=0x00
class=02-00-00, hdrtype=0x00, mfdev=0
subordinatebus=0 secondarybus=0
intpin=a, irq=10
map[10]: type 1, range 32, base 0000e000, size 8
map[14]: type 1, range 32, base a0000000, size 12
found-> vendor=0x100b, dev=0x0020, revid=0x00
class=02-00-00, hdrtype=0x00, mfdev=0
subordinatebus=0 secondarybus=0
intpin=a, irq=11
map[10]: type 1, range 32, base 0000e100, size 8
map[14]: type 1, range 32, base a0001000, size 12
found-> vendor=0x100b, dev=0x0020, revid=0x00
class=02-00-00, hdrtype=0x00, mfdev=0
subordinatebus=0 secondarybus=0
intpin=a, irq=5
map[10]: type 1, range 32, base 0000e200, size 8
map[14]: type 1, range 32, base a0002000, size 12
pci0: <PCI bus> on pcib0
sis0: <NatSemi DP83815 10/100BaseTX> port 0xe000-0xe0ff mem 0xa0000000-0xa0000ff
f irq 10 at device 18.0 on pci0
sis0: Ethernet address: 00:00:24:c1:2f:64
miibus0: <MII bus> on sis0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0: OUI 0x080017, model 0x0002, rev. 1
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bpf: sis0 attached
sis1: <NatSemi DP83815 10/100BaseTX> port 0xe100-0xe1ff mem 0xa0001000-0xa0001ff
f irq 11 at device 19.0 on pci0
sis1: Ethernet address: 00:00:24:c1:2f:65
miibus1: <MII bus> on sis1
ukphy1: <Generic IEEE 802.3u media interface> on miibus1
ukphy1: OUI 0x080017, model 0x0002, rev. 1
ukphy1: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bpf: sis1 attached
sis2: <NatSemi DP83815 10/100BaseTX> port 0xe200-0xe2ff mem 0xa0002000-0xa0002ff
f irq 5 at device 20.0 on pci0
sis2: Ethernet address: 00:00:24:c1:2f:66
miibus2: <MII bus> on sis2
ukphy2: <Generic IEEE 802.3u media interface> on miibus2
ukphy2: OUI 0x080017, model 0x0002, rev. 1
ukphy2: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
bpf: sis2 attached
isa0: <ISA bus> on motherboard
Trying Read_Port at 203
Trying Read_Port at 243
Trying Read_Port at 283
Trying Read_Port at 2c3
Trying Read_Port at 303
Trying Read_Port at 343
Trying Read_Port at 383
Trying Read_Port at 3c3
isa_probe_children: disabling PnP devices
isa_probe_children: probing non-PnP devices
orm0: <Option ROM> at iomem 0xc8000-0xd1fff on isa0
pmtimer0 on isa0
ata0: iobase=0x01f0 altiobase=0x03f6 bmaddr=0x0000
ata0: mask=03 ostat0=7f ostat2=7f
ata0-master: ATAPI 7f 7f
ata0-slave: ATAPI 7f 7f
ata0: mask=03 stat0=7f stat1=7f
ata0-master: ATA 27 27
ata0-slave: ATA 27 27
ata0: devices=00
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1: iobase=0x0170 altiobase=0x0376 bmaddr=0x0000
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
vga0: <Generic ISA VGA> failed to probe on isa0
sc0: no video adapter found.
sc0: <System console> failed to probe at flags 0x100 on isa0
sio0: irq maps: 0x1 0x11 0x1 0x1
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A, console
sio1: irq maps: 0x1 0x9 0x1 0x1
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
isa_probe_children: probing PnP devices
BIOS Geometries:
0 accounted for
Device configuration finished.
Elan-mmcr driver: MMCR at 0xc5a6e000
crypto: assign driver 0, flags 6
crypto: driver 0 registers alg 1 flags 0 maxoplen 0
crypto: driver 0 registers alg 2 flags 0 maxoplen 0
crypto: driver 0 registers alg 3 flags 0 maxoplen 0
crypto: driver 0 registers alg 4 flags 0 maxoplen 0
crypto: driver 0 registers alg 5 flags 0 maxoplen 0
crypto: driver 0 registers alg 17 flags 0 maxoplen 0
crypto: driver 0 registers alg 6 flags 0 maxoplen 0
crypto: driver 0 registers alg 7 flags 0 maxoplen 0
crypto: driver 0 registers alg 15 flags 0 maxoplen 0
crypto: driver 0 registers alg 8 flags 0 maxoplen 0
crypto: driver 0 registers alg 16 flags 0 maxoplen 0
crypto: driver 0 registers alg 9 flags 0 maxoplen 0
crypto: driver 0 registers alg 10 flags 0 maxoplen 0
crypto: driver 0 registers alg 13 flags 0 maxoplen 0
crypto: driver 0 registers alg 14 flags 0 maxoplen 0
crypto: driver 0 registers alg 11 flags 0 maxoplen 0
crypto: driver 0 registers alg 18 flags 0 maxoplen 0
bpf: lo0 attached
IPsec: Initialized Security Association Processing.
IP Filter: v3.4.31 initialized. Default = pass all, Logging = enabled
Sending DHCP Discover packet from interface sis0 (00:00:24:c1:2f:64)
Sending DHCP Discover packet from interface sis1 (00:00:24:c1:2f:65)
Sending DHCP Discover packet from interface sis2 (00:00:24:c1:2f:66)
Received DHCP Offer packet on sis0 from 172.16.34.1 (accepted) (no root path)
Sending DHCP Request packet from interface sis0 (00:00:24:c1:2f:64)
Received DHCP Ack packet on sis0 from 172.16.34.1 (accepted) (got root path)
DHCP timeout for interface sis1
DHCP timeout for interface sis2
sis0 at 172.16.34.98 server 172.16.34.1 boot file pxeboot
subnet mask 255.255.255.0 router 172.16.34.1 rootfs 172.16.34.1:/tmp
Adjusted interface sis0
Shutdown interface sis1
Shutdown interface sis2
Mounting root from nfs:172.16.34.1:/tmp
missing device name
setrootbyname failed
NFS ROOT: 172.16.34.1:/tmp


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to