(apologies in advance if this silly hotmail account adds any HTML..)

Hi all,

I have a 4.8-RELEASE server running stock Generic kernal as a NFS and samba file server. It's got a pile of standard IDE discs in it, 40 to 120Gb each, using two third party PCI IDE cards.

Within the last couple of weeks I have now had three hard disc go down - symptoms are basically that any access to the directories hosted on that drive gives a "device not configured" error. Indeed anything trying to access the drive gives the same error. even umount gives the same error...

a quick grep of the logs turns up:

Oct 5 03:03:29 luggage /kernel: ad3: READ command timeout tag=0 serv=0 - resett
Oct 5 03:03:29 luggage /kernel: ata1: resetting devices ..
Oct 5 03:03:29 luggage /kernel: ad3: removed from configuration
Oct 5 03:03:29 luggage /kernel: done

Firsttly, and most important, is there anything I can do to restore the drive? A reboot didn't ... There's not much in the top level directory of each drive, but loads in sub-folders. They are not accessed much, but I don't particularly want to lose the data. One of them is my backup drive, too...

What would you recommend to avoid problems in the future? I think it's time to build a new server anyway (this is only an AMD K6 2/500) - Would it be best to run a RAID filesystem, and would 1+0 be better than RAID5 for reslilence on future failures? Is this reliable on cheap IDE drives?

Thanks in advance,


luggage# df -h /dev/ad3s1e
df: /dev/ad3s1e: Device not configured

luggage# uname -a
FreeBSD luggage.internal.irrelevant.com 4.8-RELEASE FreeBSD 4.8-RELEASE #0: Thu Apr 3 10:53:38 GMT 2003 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC i386

It's fast, it's easy and it's free. Get MSN Messenger today! http://www.msn.co.uk/messenger

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to