On Fri, Oct 17, 2003 at 06:21:15PM +0100, Jim Hatfield wrote:
> On Fri, 17 Oct 2003 17:55:57 +0100, in local.freebsd.questions you
> wrote:
> 
> >On Fri, Oct 17, 2003 at 03:30:19PM +0100, Jim Hatfield wrote:
> >> Anyone know what causes this:
> >> 
> >> >speyburn-isis(113) pkg_info -x php
> >> >pkg_info: read_plist: bad command '@conflicts php4-cli-4*'
> >
> >You're trying to use new packages with your old FreeBSD system, which
> >is not supported.
> 
> No I'm not, these packages were installed ages ago.

@conflicts was only added to the system recently, and after the
pkg_tools were updated to understand it.  It did not exist in packages
produced "ages ago".

> But that's beside the point. Is there anything I can do to
> fix it?

Update to RELENG_4, remove the incompatible packages, or edit the
+CONTENTS manually to remove the directive your older pkg_tools does
not understand.

Kris

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to