From: Andrew Kozak
Date: Monday, 20 October 2003 05:42:11 PM
To: FreeBSD Questions
Subject: GTK
 
  
Hi Everyone
 
Hope someone can help me here, I've kinda stuffed up big time. Whilst trying
to install etherape, I received a message that my gtk was too old, and that
I should uninstall it and install the new one. Which I did. Immediately
afterwards, I found that quite a few programs rely on this older version of
gtk I have lost all web browsers other than knoqueror (missing dillo, what a
nice efficient fast little browser that is). I am using FreeBSD 4.9RC on a
Pentium 2 with 128Mb of RAM. I have downloaded the gtk version that used to
run the broken programs (version 1.2.0) and tried to ./configure, which goes
ahead, but complains about glib not being there, so I downloaded that, still
complains that glib is not there. I did download version 1.2.0 and did the
/configure but no good, still complains that this file is missing. The error
I get if I try and run one of the broken programs is /usr/libexec/ld-elf.so
1: Shared Object "libintl.so.4" not found If I do a locate libintl.so.4, the
machine tells me that is is located in libexec, right where it should be,
however, when I log into that directory and look, It's not there - and I
have been logging in as root to make sure that I get all privileges and can
see hidden files.
 
I have tried to reinstall some of the broken ports, but once again, I get an
error stopping the build process. It is
 
Could not run the GTK test program, checking why..............
The test program compiled but did not run. This usually means that the
run-time linker is not finding GTK or finding the wrong version of GTK. If
it is not finding GTK, you'll need to set your LD-LIBRARY_PATH environment
variable, or edit /etc/ld.so.conf to point to the installed location Also,
make sure you have run ldconfig if that is required on your system.
 
If you have an old version installed, it is best to remove it, although you
may also get things to work by modifying LD_LIBRARY_PATH.
 
Line about Linux
 
configure: error: Unable to find Gtk+ with a version >=1.2.0. Dillo needs
Gtk+
===> Script configure failed unexpectedly.
 
Tried pkgdb -F, hasn't worked either.
 
Please don't bother if you are a 'boffin' who likes big words such as just
hiblib the hoobiwhastis with alt 67 and configure the path to match the
environment via port 28774. Don't get me wrong, I'm not unappreciative, but
it goes over my head, and is a waste of time for all of us. I do not
understand code or programming, I am just a workstation operator who is
trying to learn this flexible powerful system. I hope to be able to discuss
and understand terminology associated with code and programming when I get
my head around the basics and have an  opportunity to learn more. I am a
newbie and need laymen terms to understand.
 

All help appreciated.
Thank You
Andy Kozak
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to