> On Monday 20 October 2003 01:18 am, Matthew Seaman wrote:
> > On Mon, Oct 20, 2003 at 03:49:33PM +0800, Michael Lee(HINET) wrote:
> > > Is there anyway to avoid updating XFree86 related stuff while
performing
> > > portupgrade ?
> > > XFree86 related stuffs are just too big and take too long for my poor
PC
> > > to compile them all.
> >
> > Take a look at the pkgtools.conf file, especially the stuff about
HOLD_PKGS
> > which does exactly what you want.
> >
>
> Also look at the man page for portupgrade. The example for -x is exactly
what
> you are talking about.
>

Thanks Kent and Matthew.

Now I know the way to manipulate the actions of portupgrade for not
upgrading everything.
I just posted earlier another question for portupgrade not being able to
upgrade
the installed apache-1.3.27_4 to apache-1.3.28

Some applications ( phpMyAdmin, mod_php4, mod_fastcgi ) that depends on
apache could not be
upgraded either.

I tried to portupgrade -rR apache but after a series of compilation, it
failed.

Here I would like to repost the error messages ( snip some ) and hope that
someone can help me.

I wonder if I should uninstall them all first and then portupgrade -N
....( apache-1.3.28, mod_php4, mod_fastcgi, phpMyAdmin )

or I can just do portupgrade -f to force it update to the newer version ?

Thank you again!

Michael Lee

Stop in /usr/ports/www/apache13.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade5405.2
make WITH_APACHE_SUEXEC=yes reinstall
egrep: /var/db/pkg/apache-1.3.27_4/+CONTENTS: No such file or directory
--->  Restoring the old version
** Fix the installation problem and try again.
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 78 packages
found (-0 +1) . done]
--->  Skipping 'www/mod_fastcgi' (mod_fastcgi-2.2.12) because 'www/apache13'
(apache-1.3.27_4) failed
--->  Skipping 'www/mod_php4' (mod_php4-4.3.1,1) because 'www/apache13'
(apache-1.3.27_4) failed
--->  Skipping 'www/mod_gzip' (mod_gzip-1.3.26.1a) because 'www/apache13'
(apache-1.3.27_4) failed
--->  Skipping 'databases/phpmyadmin' (phpMyAdmin-2.3.2) because
'www/mod_php4' (mod_php4-4.3.1,1) failed
** The following packages were not installed or upgraded (*:skipped /
!:failed)
        ! www/apache13 (apache-1.3.27_4)        (install error)
        * www/mod_fastcgi (mod_fastcgi-2.2.12)
        * www/mod_php4 (mod_php4-4.3.1,1)
        * www/mod_gzip (mod_gzip-1.3.26.1a)
        * databases/phpmyadmin (phpMyAdmin-2.3.2)

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to