----- Original Message ----- 
From: "Lowell Gilbert" <[EMAIL PROTECTED]>
To: "Michael Lee(HINET)" <[EMAIL PROTECTED]>
Cc: <[EMAIL PROTECTED]>
Sent: Tuesday, October 21, 2003 9:03 PM
Subject: Re: question for portupgrade


> "Michael Lee(HINET)" <[EMAIL PROTECTED]> writes:
>
> > Hi,
> >
> > After cvsupping the port tree ( originally installed by FreeBSD 5.1
Release
> > CD ),
> > I tried to do a portupgrade -acCv last night.
> > Everything seems to be upgraded fine except for Apache.
> >
> > The originally installed apache is apache-1.3.27_4. The portupgrade
attempts
> > to upgrade it from
> > apache-1.3.27_4 to apache-1.3.28.
> >
> > Should I command portupgrade -f apache to force it update to the new
version
> > ?
> > Or will it be better for me to first uninstall apache then do
portupgrade -N
> > apache ?
> >
> > Since I also installed mod_fastcgi, mod_php4, mod_gzip, and phpMyAdmin
> > previously,
> > I think these packages depends on apache.
> >
> > Any suggestion ?
> >
> > Thanks!
> >
> >
> > Here is the error message I got.
> >
> > Stop in /usr/ports/www/apache13.
> > ** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade5405.2
> > make WITH_APACHE_SUEXEC=yes reinstall
> > egrep: /var/db/pkg/apache-1.3.27_4/+CONTENTS: No such file or directory
> > --->  Restoring the old version
> > ** Fix the installation problem and try again.
> > [Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 78 packages
> > found (-0 +1) . done]
> > --->  Skipping 'www/mod_fastcgi' (mod_fastcgi-2.2.12) because
'www/apache13'
> > (apache-1.3.27_4) failed
> > --->  Skipping 'www/mod_php4' (mod_php4-4.3.1,1) because 'www/apache13'
> > (apache-1.3.27_4) failed
> > --->  Skipping 'www/mod_gzip' (mod_gzip-1.3.26.1a) because
'www/apache13'
> > (apache-1.3.27_4) failed
> > --->  Skipping 'databases/phpmyadmin' (phpMyAdmin-2.3.2) because
> > 'www/mod_php4' (mod_php4-4.3.1,1) failed
> > ** The following packages were not installed or upgraded (*:skipped /
> > !:failed)
> >         ! www/apache13 (apache-1.3.27_4)        (install error)
> >         * www/mod_fastcgi (mod_fastcgi-2.2.12)
> >         * www/mod_php4 (mod_php4-4.3.1,1)
> >         * www/mod_gzip (mod_gzip-1.3.26.1a)
> >         * databases/phpmyadmin (phpMyAdmin-2.3.2)
>
> Your package-database entry for Apache is corrupt.  Either of your
> suggestions ('portupgrade -f' or deleting and rebuilding) should work,
> but I would tend to do it by hand to keep a closer eye on it (in case
> something else goes wrong, primarily).  Your choice.
>

Thanks for your suggestion.
I finally did pkg_delete apache, mod_fastcgi, mod_php4, mod_gzip, and
phpmyadmin and reinstall them all
from the begining.
I don't know why the package database was corrupt if I follow the "normal"
way to
portupgrade them.
It could be quite annoying if there are a lot of packages depends on a
single corrupted package.
(since I have to first deinstall them and reinstall them. Just take a lot of
time. )

Michael Lee

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to