On Fri, Oct 24, 2003 at 11:23:03AM -0400, Jesse Guardiani typed:
> Howdy list,
> 
> I have a port that I do NOT want to upgrade: python-2.2.2
> If I do upgrade it, some of the software on my system will
> not work correctly.
> 
> However, I'd still like to use portupgrade -R on a few
> ports to upgrade all dependencies EXCEPT python.
> 
> Is there a way to mark a port as non-upgradable?
 
Yes, see /usr/local/etc/pkgtools.conf

  HOLD_PKGS = [
    'bsdpan-*',
    'x11*/XFree86*',
    'portupgrade',
    'python-*',
  ]

> Thanks.
> 
> -- 
> Jesse Guardiani, Systems Administrator
> WingNET Internet Services,
> P.O. Box 2605 // Cleveland, TN 37320-2605
> 423-559-LINK (v)  423-559-5145 (f)
> http://www.wingnet.net
> 
> 
> _______________________________________________
> [EMAIL PROTECTED] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "[EMAIL PROTECTED]"
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to