I've been having a bit of an issue with my 120gb Maxtor hard drive under
FreeBSD.  As of right now, the disk is set up with one NTFS partition,
but I'm not sure if thats relevant.  BIOS reports the correct geometry
and size, and Windows also reports the correct size.  The disk is ad1.

If do a dmesg, I get these messages relating to the drive:

ad1: 2014MB <Maxtor 4G120J6> [4092/16/63] at ata0-slave UDMA100
ad1s3: slice extends beyond end of disk: truncating from 240091425 to
4108671 sectors
ad1s5: slice extends beyond end of disk: truncating from 167782797 to
4108608 sectors

Steps I've already tried (in no particular order):
1.  A friend said that I could disable the drive in BIOS, and FreeBSD
would query the controller, and get the info from there.  I did disable
it, but I got the same results.
2.  Checked in Windows XP is the disk is set to a "dynamic disk."  I
understand they are not compatible with any operating system besides
XP.  The disk is listed as "Basic"
3.  I've tried taking the geometry from BIOS and manually putting it in
from fdisk in sysinstall.  With the values copied verbatim, fdisk says
that they are incorrect, and will not use them.  I have also used the
geometry published by Maxtor.  Those numbers work, but the hard drive is
only around 8gb.
4.  I was advised on IRC to try switching the drive from its position at
primary slave, to somewhere else.  I changed it to secondary slave, and
had the same results.

The Values that BIOS gives:
58853 cyls
16 heads
255 sectors

Values from Maxtor
16383 max cyls (238216 actual)
16 heads
63 sectors

The Values that BSD reports (from fdisk):
256 cyls
255 heads
63 sectors

Thanks a lot.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to