On (2003/10/30 18:16), Sheldon Hearn wrote:

> > I'm using SMBFS on FreeBSD 4.9-PRERELEASE from 2003-09-18, and running
> > into problems mounting W2K shares.  I was last able to mount these
> > shares a month ago.  Since then, the only change I'm aware of was the
> > world update (to catch security patches) and accompanying mergemaster.
> I've just tried with FreeBSD 4.9-STABLE, using today's sources and I
> still get:
> > # mount /smb/foo
> > smbfs: unable to open connection: syserr = RPC struct is bad
> Backups are suffering.  Any ideas (even shots in the dark) would be
> helpful.

Found the problem.

The Windows user "backup", as which the FreeBSD box authenticates when
mounting the Windows shares, was created on the domain controller
without "Password never expires" enabled, and the business concerned
doesn't have a password recycling policy designed to handle automatic
password expiry of system accounts.

SMBFS expects one of several responses to the authentication phase, but
"your password has expired, please change it" isn't one of them.  I'll
send my findings to Boris, the author of our SMBFS support.

At least this is in the archives, now. :-)

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to