* stevens root:

> I have installed FreeBSD 5.1 release+KDE 3.1,my sound card is Creative
> SB Vibra 128,I haved added "device  pcm" to kernel and rebuided it,but
> when  I  reboot  my  computer,the system  can't  initilize  my  card,I
> type"dmesg|grep  pcm"  without output,when  I  start  kde, the  system
> noticed me that no /dev/dsp found(no such file),what can I do?

The only device that works for me is /dev/dsp1.0.  But grep'ing dmesg
gives results.

$ ls /boot/kernel/snd_*
/boot/kernel/snd_ad1816.ko    /boot/kernel/snd_ess.ko       /boot/kernel/snd_sb8.ko
/boot/kernel/snd_als4000.ko   /boot/kernel/snd_fm801.ko     /boot/kernel/snd_sbc.ko
/boot/kernel/snd_cmi.ko       /boot/kernel/snd_ich.ko       /boot/kernel/snd_solo.ko
/boot/kernel/snd_cs4281.ko    /boot/kernel/snd_maestro.ko   /boot/kernel/snd_t4dwave.ko
/boot/kernel/snd_csa.ko       /boot/kernel/snd_maestro3.ko  /boot/kernel/snd_uaudio.ko
/boot/kernel/snd_driver.ko    /boot/kernel/snd_mss.ko       /boot/kernel/snd_via8233.ko
/boot/kernel/snd_ds1.ko       /boot/kernel/snd_neomagic.ko  
/boot/kernel/snd_via82c686.ko
/boot/kernel/snd_emu10k1.ko   /boot/kernel/snd_pcm.ko       /boot/kernel/snd_vibes.ko
/boot/kernel/snd_es137x.ko    /boot/kernel/snd_sb16.ko

$ grep pcm /usr/src/sys/i386/conf/WATT
device          pcm

$ dmesg | grep pcm
pcm0: <VIA VT82C686A> port 0xd400-0xd403,0xd000-0xd003,0xcc00-0xccff irq 11 at device 
7.5 on pci0
pcm0: <ICEnsemble ICE1232 AC97 Codec>
pcm1: <Creative CT5880-C> port 0xdc00-0xdc3f irq 5 at device 9.0 on pci0
pcm1: <SigmaTel STAC9721/23 AC97 Codec>

Cheers,
-- 
Jean-Baptiste Quenot
http://caraldi.com/jbq/
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to