I installed XFree86, then i run XFree86 -configure, then i run XFree86 -xf86config XF86Config.new.
Everything is ok. Than i cp XF86Config.new to /etc/X11/XF86Config (i tried to copy and to
/usr/X11R6/etc/X11/XF86Config but there is no directory X11). then, when i run startx i get the
next error: screen not found... I know i can do everythiing with xf86cfg but i don`t understand
why the first way has problems (may be i have problems :)))) ). Thank You!



Hi;


Please wrap your lines at < 80 characters.

It is not clear. Did you create the file /etc/X11/XF86Config?
If there is no /etc/X11 directory, you can create it with:
mkdir /etc/X11

Is it possible there is another XF86Config floating around out there
that you are actually using?  Try looking at /var/log/XFree86.0.log

Mine says:

XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: FreeBSD 4.9 i386 [ELF]
Build Date: 15 October 2003
       Before reporting problems, check http://www.XFree86.Org/
       to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Nov  3 22:24:11 2003
(==) Using config file: "/etc/X11/XF86Config"
[...]

So, it tells you which config file it is using.

Also, have you installed the /usr/ports/x11/wrapper port yet?
You will need that to startx as a regular user.

PS> a better title for this post would be: startx gives "screen not found"
      or something along those lines  :o)

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. http://join.msn.com/?page=features/featuredemail


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to