> > I'm running freebsd 4.8-STABLE, I installed it a
> > little while ago and it has been running fine as
> my
> > broadband router for a few weeks now, no problems.
> > 
> > This morning there was a powercut, and when I came
> to
> > the machine and attached a monitor, I discovered
> that
> > it was making it through the BIOS, getting to the
> > spinning -\|/-\|/ prompt, where it freezes on the
> > first | every time.
> Uh-oh.  That's bad.  That shows the system is trying
> and failing to
> read the kernel from your hard drive.  
> If so, first thing to try is running fsck on your
> root partition:
>     # fsck -y /dev/ad0s1a

Thought I'd just reply to say how this one panned out
in case it helps anyone trawling the archives in the

I booted off the CD, ran fsck, got bad super block
messages.  Unable to fix it by recommended methods, I
was becoming frustrated and came close to wiping the
disk for a reinstall.  Instead I put it in one of my
other machines, and it booted my system fine.  Then
into a third machine, that worked fine as well.

Once it was clear that the disk was not the cause of
the problem, I began to poke around a lot in the BSD
machine, and eventually found that what had happened
was that the powercut had caused the CMOS to flip the
"type" option for my hard disk from "normal" to "auto"
(not really a noticeable difference imho!), changing
this back meant it worked fine again.

So just one of those random incidents really!  Thanks
for the help given :)


Download Yahoo! Messenger now for a chance to win Live At Knebworth DVDs
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to