> I want to build a new kernel. I have edit the GENERIC
> file (like is written into the documentation). And
> when i run /usr/sbin/config
> /root/kernels/MYKERNEL(this is my kernel) i get a lot
> of errors Command not found. What is made wrong???

First of all, I presume you really used one line as

  /usr/sbin/config /root/kernels/MYKERNEL

Not two separate command lines as it appears in your message.

Secondly, did you make your copy of GENERIC in to the
same directory as GENERIC?    That is the best idea.

Third, on any of the FreeBSD systems I have worked on there is
no /root/kernels directory.   (If this is something new with 5.x I
am off on this as I haven't built a 5.x yet)  The kernel
config files are in:  /usr/src/sys/i386/conf  (or did you set up
some homebrew link?)   So, I would expect that there is a file:

and the best way to run things is to
  cd /usr/src/sys/i386/conf
  vi MYKERNEL        (make whatever changes you need and write+exit vi)
  /usr/sbin/config MYKERNEL
  cd ../../compile/MYKERNEL
  make depend
  [make install]   Only if you want the present kernel replaced

Now if you have CVSUPed and etc, then you will want to follow those
instructions instead of merely building a kernel.   Doing it
the above way is only if you are just changing the kernel config 
and then recompiling.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to