I'm having trouble doing a binary upgrade from 4.3 to 4.9.

Existing 4.3 was installed with 'all' distributions selected, and takes up
about 636M on an old Pentium.

When I tried the upgrade to 4.9 the first time (selecting 'all' again) the
process bombed, and complained about unwillingness to upgrade /src,
suggesting CTM or CVSup - which was fair enough, since this was supposed to
be a 'binary' upgrade.  (Does this always happen??)

Re-installed 4.3 again and re-tried the upgrade - this time with all
distributions chosen (except sources).  Bombed out again, complaining about
'unable to extract stuff into /usr/X11R6 directory'.  However, even with
this outcome, the system seems to be working (almost) OK.  Boots OK with 4.9
kernel and 'uname -a' shows Version 4.9.  All of the files seem to be there
(now takes up 822M), and all of the files I've checked have dates of Oct 27
(which I assume is when 4.9 was built).

However, all of my old configuration files are still stuck in /usr/tmp/etc
and have not been copied back into /etc - only 'new' unmodified versions of
the files are there, also with dates of Oct 27.  And, I assume, there are
troubles in the X11R6 directory, since that's where it was when it bombed.

So, it appears that the upgrade went almost to completion, but ran into
trouble towards the end.

Any suggestions??  I'm beginning to believe that binary upgrades are more
trouble than a 'real' one - even though it 'appears' to be easier.

Cal Cornils
Napa Valley College
Beautiful Napa Valley

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to