On Mon, Dec 15, 2003 at 10:35:54AM -0800, Chris wrote:
> Hello all, 
> I decided to upgrade to little test server to a more recent PHP & MySQL (as well as 
> Apache
> 2.0.48). Everything is working, but I still have a problem. I installed mysql from 
> the port. I
> installed PHP from source, but no matter what I tried giving ./configure for the 
> --with-mysql
> value, I got complaints. When I tried the actual mysql install dir, I got complaints 
> that
> ./configure couldn't find a header file. When I tried the actual work subdir for the 
> mysql port
> itself, I got an error that it couldn't find the mysqlclient library.
> As a result I'm going with PHPs builtin mysql support -- unfortunately, the built-in 
> version is
> 3.23.xx, and I really want 4.0.
> Google got me a suggestion that I need to download something called mysql-devel for 
> my version of
> mysql. However, I've only found this as an RPM, and I'm wondering if what I read 
> before was just a
> Linux answer.
> Does anyone know what to do?
> Thanks,
> The Bean

Just for kicks I tried installing /usr/ports/www/mod_php4 out of the ports on 
a cleanly installed 5.2-CURRENT box with a ports cvsup from about 3 days ago.  
It immediately installed apache 1.3.29, then did this: 

===>   Returning to build of mod_php4-4.3.4_2,1
===>   mod_php4-4.3.4_2,1 depends on executable: bison - found
===>   mod_php4-4.3.4_2,1 depends on shared library: expat.4 - found
===>   mod_php4-4.3.4_2,1 depends on shared library: mysqlclient.12 - not found
===>    Verifying install for mysqlclient.12 in 
>> mysql-4.0.16.tar.gz doesn't seem to exist in /usr/ports/distfiles/.

Isn't that the 4.x support that you're looking for?

Josh Paetzel

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to