I have a Dell PowerEdge 2650 with one 2.8G Xeon CPU and 2G RAM running 
5.1-RELEASE.  This machine is a dedicated NFS server.  Everything on the 
system is "default": no custom kernel, no custom filesystem options, no 

Earlier today I ran "rm -R" on a directory containing millions of files 
in its various subdirectories.  Within a minute or so the machine hung, 
NFS stopped working, and I had a posse of angry computational linguists 
knocking on my door.  I ^Ced to no avail.  So I tried opening another ssh 
session--no luck.  I pinged.  I nmapped.  Nothing.  I jumped up and ran 
to the server room.  By the time I got there it was back up (whew!) but 
it had rebooted itself in the process (d'oh!).

The directory, or most of it, was still there.

I tried not to think too much about it.  I went to the annual holiday 
party.  I had a few adult beverages.  I woke up a little while ago with a 
mysterious and slightly painful bump on my forehead and something 
scribbled on my dining room table with a green Sharpie*.  It seemed as 
good a time as any to try deleting that directory again.

So I did.  With identical results.  The machine hung for a few minutes 
and then spontenously rebooted.

The total size of the directory is ~100G.  It lives on a 1T UFS2+S 
partition of a 7x200G hardware RAID 5 array, which itself lives in a 
16x200G ATA-to-SCSI cabinet.  The directory contains millions of tiny 
files collected by a "website harvesting" project.

Any thoughts as to why this might be happening?


Jason M. Leonard                        Linguistic Data Consortium
Systems Administrator                   University of Pennsylvania
[EMAIL PROTECTED]                       215.573.3959 vx   .2175 fx

*In all fairness to myself, the surface of my dining room table does 
resemble markerboard.  And Sharpies do resemble dry erase markers.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to