> I have been trying to get FreeBSD onto a CF, and had an assortment of
> issues.
> 
> I now have a version of FreeBSD 5.X CURRENT that is compiled and
> configured in the way I want by some people that are doing the same thing
> I am.
> 
> They use dd to flush this archive to a cf that is installed as an IDE
> drive, so I tried to do the same thing.
> 
> The test system I am using to write this has two hard drives, but not
> hooked up at the same time.  One is 5.1, the other is 4.9
> 
> I get the following message with 5.1:
> 
> dd: /dev/ad2: Input/output error
> 1+0 records in
> 0+0 records out
> 0 bytes transferred in 0.003308 secs (0 bytes/sec)
> 
> So in case it was something odd, I went to the 4.9 and get this:
> 
> dd: /dev/ad2: Input/output error
> 
> Next I did tail /var/log/messages
> 
> Dec 19 14:47:01 wanker /kernel: ad2: hard error reading fsbn 0 (ad2 bn 0;
> cn 0 tn 0 sn 0) status=51 error=05
> Dec 19 14:47:01 wanker /kernel: ad2: reading primary partition table:
> error reading fsbn 0
> 
> (error repeats several times)
> 
> Most the posts I have seen with "hard error reading fsbn 0" relate to the
> PIO mode, which is absolutely no help.
> 
> Anyone have an idea where to start?

I don't know if it will help in any way, but it may be a start.

Last time I tried to do a clone of one of our mail servers, I got an
error very similar. We rectified the problem by putting a proper 80
conductor/40 pin cable to the hard disk, which replaced the standard 40
pin cable. If you indeed have a UDMA capable board, I'd at least give
this an option.

Steve

> 
> --Eric
> 
> _______________________________________________
> [EMAIL PROTECTED] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to