Ok, I admit I've never encountered this issue before, so I'm stumped. Being the cautious type I first installed Freebsd by removing my backup drive and booting that way. That was to prevent myself from acidentily nuking my secondary drive which is my backup/storage drive. Ok, Freebsd install goes great and I'm now ready to add the second HD back in and mount it. One problem. Upon boot it loads the ATA drivers for ata0 and ata1 (primary and secondary IDE controlers) and then it tries to initialize ad0 which it successfully does, but it gets a read error on drive 2 which is ad1. If I run these drives on separate controlers I have zero issues, but when they're together as master/slave, whichever drive is slave refuses to initialize, however the bios sees it fine. I've got it running with the cdrom and drive2 on the secondary IDE and drive1 on the primary IDE. Thing is, they worked fine as master/slave before I reloaded BSD. Interestingly enough, even the boot floppy for installing the OS gives a fit about this.

So in short until I unplugged the second drive and switched it from master to single and back to master I didn't have any issues. Since the drives are UFS I can't test this with dos to see if it sees both drives. About all it could test is if it could see the partitions. I admit this isn't really all that bad as the system is working, but I'm worried that having the cdrom connected to the 2nd HD on the same controler will cause it to slow down the 2nd HD.

Anyone got any recommendations on how to correct this HD problem? First drive is a 40g WD, second drive is an 80g WD. Both UFS formatted. The 40g drive has the OS on it, the 80g drive is drive2, the backup drive.


_______________________________________________ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-questions To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to