Howdy list,

I've got an old copy of Wordperfect (now deleted from ports) that I use at work.

When I run the program, I get this output:

% xwp
/usr/local/lib/corel/wpbin/xwp: can't load library 'libXt.so.6'
Exit 16

Obviously a dynamic link problem, so I run ldd on it:

% ldd -a /usr/local/lib/corel/wpbin/xwp
        libXt.so.6 => not found
        libX11.so.6 => not found
        libXpm.so.4 => not found
        libm.so.5 => not found
        libc.so.5 => /usr/lib/libc.so.5 (0x28749000)

OK. Fair enough. It can't find the first four libraries.
But why? libXt.so.6 is listed by ldconfig:

% ldconfig -r | grep libXt.so.6
        140:-lXt.6 => /usr/X11R6/lib/libXt.so.6

So are the other three:

% ldconfig -r | grep libX11.so.6
        162:-lX11.6 => /usr/X11R6/lib/libX11.so.6

% ldconfig -r | grep libXpm.so.4
        143:-lXpm.4 => /usr/X11R6/lib/libXpm.so.4

% ldconfig -r | grep libm.so.5
        712:-lm.5 => /usr/compat/linux/usr/i486-linux-libc5/lib/libm.so.5

So how do I fix this?

Thanks!

-- 
Jesse Guardiani, Systems Administrator
WingNET Internet Services,
P.O. Box 2605 // Cleveland, TN 37320-2605
423-559-LINK (v)  423-559-5145 (f)
http://www.wingnet.net


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to