On Wednesday 24 December 2003 06:31 am, [EMAIL PROTECTED] wrote:
> I've done what you said and could rebuild some packages including
> gettext and pkgconfig but the previous error message remains for
> applications running ld-elf. For example gkrellm - which I could
> rebuild easily - still aborts at runtime with "ld-elf.so.1 : Shared
> object libintl.so.4 not found". There is no way to install gkrellm2
> (because of pango complaining "ld-elf.so.1 :
> /usr/X11R6/lib/libfontconfig.so.1: Undefined symbol
> "FT_Get_BDF_Property""). Mozilla does not work nor build anew either.
> Mozilla-devel aborts during configure warning it does not find
> libraries and asking to setenv PKG_CONFIG_PATH, which does not help.
> The other applications seem to work well.
> I think also that I made errors with pkgdb -F .
> Is there a way to fix this ?
> Do you think that a portupgrade of all packages could help ?
> How would I recover the correct dependency lists if I corrupted them
> with pkgdb -F?

You are in a situation I have never faced. I have done a 
portupgrade -pufa 
before. I have also seen people use something like -rRa. What will work 
depends on what you have installed, what you have messed up using pkgdb -F, 
and what you will put up with while it is upgrading. On my AMD 2400+ XP, a 
full upgrade of my ports takes a long time.

When the default went to XFree86-4, I deleted all of the packages and did meta 
port builds and installs of XFree86 and KDE. The build machine spent most of 
the whole day doing this. Topaz, which is the machine I am typing this on, 
wasn't affected until ruby finished building everything. I ftped all of the 
packages from /usr/ports/packages/All, deleted what I had installed on topaz, 
and did meta-port pkg_add from the ../All directory on topaz. Topaz wasn't 
down very long.

FWIW, I don't believe in building cvsup. It is one port that I use the 
package. The modula library requires too much computer time to build and 
isn't needed by any other port.

> In the worse case how could I get rid of all my ports and pkgs and
> rebuild them from scratch without messing the system ?

You never want to mix the two. If something goes wrong, you don't have any 
idea what broke it. Did you upgrade to 4.9-release?

If you have finished upgrading to 4.9, I don't think it is part of the problem 
right now. You just have to catch your ports up to what is current and a full 
portupgrade might work. I think I would include the "f" option to force the 

Your ports include libraries from the system and you want to upgrade these to 
4.9 anyway and a full upgrade would do that. You may just have to build a few 
manually. I always use "portupgrade -puf port" because I will use the package 
on my other systems. 

If your port structure is equivalent to 4.9-release, you could update much 
faster using ftp to grab packages from freebsd.org. It all depends on your 
network connection speed. The last time I looked at packages/All on my 
freebsd.org mirror, they were all dated 11 November. Man portupgrade talks 
about using "portupgrade -aPPR" to do a massive network binary upgrade. You 
need some feedback from someone who has done this. I run 4.9-stable and it 
can never find a package for -stable and fetches the distfiles and builds the 

What ever you do, upgrade portupgrade and its dependancies first. The current 
version will fix most bad situations that you would have had to delete 
packages and re-add them before. You may still have to do that because you 
have a corrupted setup.


> > On Wednesday 24 December 2003 12:47 am, [EMAIL PROTECTED] wrote:
> >> Hi,
> >>
> >> I've been upgrading from 4.7 to 4.9 recently. Unfortunately I forgot
> >> to
> >> make world for a while , after having cvsuped (sys and ports). In the
> >> meantime I installed several ports and things were not going too bad ,
> >> but in some cases I had to ignore error messages (e.g. with Qt). It's
> >> after having tried to ugdate pkgconfig without success that I realized
> >> my errors. The port refuse to install and several applications that
> >> use
> >> ld-elf.so.1 abort complaining "Shared object lib***.so.4 not found",
> >> where *** can be "SDL", "intl", for instance.
> >>
> >> Now I used "make world" correctly but this failure persists. I'm
> >> afraid
> >> many ports won't work well or even install. What can I do?
> >>
> >> Thank you in advance and merry Christmas!
> >
> > I don't know what the SDL is but libintl.so.4 was created by an old
> > version of
> > gettext. The current version produces .so.5. You need to rebuild all
> > of them.
> > I image SDL is also one of your out of date references.
> >
> > Kent
> >
> > --
> > Kent Stewart
> > Richland, WA
> >
> > http://users.owt.com/kstewart/index.html

Kent Stewart
Richland, WA


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to