On Thu, Jan 01, 2004 at 01:19:36PM -0500, Lowell Gilbert wrote:
> Lou Katz <[EMAIL PROTECTED]> writes:
> 
> > The make runs ok
> > The make install chugs along until:
> > 
> >     chmod 755 /usr/local/libexec/apache2/mod_authz_svn.so
> >     [activating module `authz_svn' in /usr/local/etc/apache2/httpd.conf]
> >     subversion/svnversion/svnversion . /repos/svn/trunk > 
> > /usr/local/include/subversion-1/svn-revision.txt
> >     /usr/libexec/ld-elf.so.1: /usr/local/lib/libapr-0.so.9: Undefined symbol 
> > "pthread_mutex_init"
> >     *** Error code 1
> > 
> >     Stop in /work/local1/ports/devel/subversion/work/subversion-0.32.1.
> >     *** Error code 1
> > 
> >     Stop in /work/local1/ports/devel/subversion.
> > 
> > 
> > 
> > I have checked, and there is libpthread.so.20 in /usr/local/lib/pth which I have 
> > linked
> > up into /usr/local/lib, and it has the symbol "pthread_mutex_init". 
> 
> Sounds like you're working with an older version of FreeBSD.
> [Please see Greg Lehey's "How to get best results from FreeBSD-questions" 
>  http://www.lemis.com/questions.html ]

4.7-RELEASE-p4


> 
> The ports aren't particularly intended to work with older versions,
> and may depend on newer features (like some of the pthread modifications).

If I leave MOD_DAV out, it works, but I think I need that. The funny thing
is, the library with pthread_mutex_init IS IN /usr/local/lib!

Thanks.

-- 
-=[L]=-
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to