In the last episode (Jan 02), Toomas Aas said:
> However, when I umount /backup and remove the drive, the da0 device
> somehow remains active (can be seen with 'camcontrol devlist'). When
> I then plug in the second drive, it becomes da1, which spoils all my
> beautiful backup plans. I would prefer that when I remove one drive
> and plug in the other, it becomes da0 again. So I need to get the
> 'old' da0 entry to go away when unplugging the drive. How can I do
> that?
> 
> I tried 'camcontrol rescan 0:0:0' after disconnecting the drive, but
> it just hangs until I plug the drive back in. I tried 'camcontrol
> reset 0', but this returned error 0x6 (IIRC).

Try just "camcontrol rescan 0" to rescan the entire FW bus.  I don't
know if scanning just a single LUN will allow the whole device to
disappear.  I think it was more intended for SCSI/FC RAIDs, so you
could add/remove/resize volumes.  Just guessing here, though.

-- 
        Dan Nelson
        [EMAIL PROTECTED]
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to