T Kellers wrote:

On Friday 02 January 2004 08:32 pm, Trey Sizemore wrote:

T Kellers wrote:

On Friday 02 January 2004 06:49 pm, Trey Sizemore wrote:

Eric F Crist wrote:

On Friday 02 January 2004 02:06 pm, T Kellers wrote:

Don't use both device pcm and the .ko modules. The sound won't work at
all or, if it does, not properly. You may not even have any keyboard
beeps (^G's) if both are loaded.

I find I only add the device pcm line to my kernel and everything works
fine. Gnome, KDE, console beeps.  Everything works and I don't usually
worry about the sound servers.  When you install one of the window
managers, as long as you install the multimedia package, the correct
sound server gets installed too.  This has been working for me for about
5 years now.


Update here...I have removed the entries in /boot/loader.conf and now
only have the kernel compiled with my 'device PCM' entry.

'dmesg | grep pcm' shows my soundcard entry and cat /dev/sndstat shows
it as well.

I have rebooted after taking the entries out of loader.conf.

When I try something like

% play KDE_Beep_Ahem.wav

I get:

play: /dev/dsp: Operation not supported by device

What might be causing this that I could look into?

%play /usr/local/share/sounds/KDE_Beep_Ahem.wav
play: /dev/dsp: Operation not supported by device

I get that same message after I've shut down the arts server

artsplay /usr/local/share/sounds/KDE_Beep_Ahem.wav

works fine as long as artsd is running

%ps -ax | grep arts
14333  p0  S      0:01.69 artsd
14343  p0  R+     0:00.00 grep arts

If you have KDE installed, try:

%artsd &
%artsplay /usr/local/share/sounds/KDE_Beep_Ahem.wav

You should hear Mr Ahem clear his throat right from the command line.


Tried that and I get the following:

Can't connect to sound server

Please try: ps -ax | grep arts

and see if artsd is running

If you start it manually you need to run artsd & before you type the test file entry.

Tim Kellers

Yes, it's running. When I run the command from the command line now, it jumps right to the next line waiting for further input. It's as if it played it as requested but I hear nothing. My volume is up on the speakers, mixer levels are good...just no sound. :-(

No console beeps either.

This is in KDE.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to