Subhro,

On Jan 3, 2004, at 10:54 PM, Subhro wrote:

Hey Will,
Do you remember if you added anything nonstandard to CFLAGS in
/etc/make.conf?

I dont thin I have added anything to /etc/make.conf. I can confirm once the system is up again. SSHD did not start up at boot after the crash so I am trying to have someone in the colo start it manually, hoping that will get me in!!


Something like -funroll-loops or some non standard
optimizations? Also what is the securelevel you are running the system at?

I am not sure, probably 0.


Did u specifically mention to OVERWRITE the base system and did u add the
line sshd_script="/usr/local/sbin/sshd" in /etc/rc.conf?

Yes, those are done. That is why I wonder why no sshd started at bootup. I sure hope the team over at the colo can get sshd running.


IF u did all of
these then I would recommend add NO_OPENSSH="YES" to /etc/make.conf and
rebuild the world. Also go through a CVSup before the rebuild. Also if
possible paste the last 25 lines of /var/log/messages. As far as I can make
out without the logs, somehow the sshd code has got to become incompatible
with the rest of the source tree.

OK. Let me get the machine up and I would gladly send you some of the messages.


Thanks again!!


Cheers! Subhro

-----Original Message-----
From: Will Prater [mailto:[EMAIL PROTECTED]
Sent: Sunday, January 04, 2004 11:00 AM
To: Subhro
Cc: [EMAIL PROTECTED]
Subject: Re: sshd crashing server

Subhro,

I have done this and tried another command that would spew some data
and the machine crashed again. Any more ideas why the sshd process
would be choking and crashing the server?

I cant send you an example as I am locked out. Looks like sshd is not
starting after the new port install described below.


Regards


Will

On Jan 3, 2004, at 1:09 PM, Subhro wrote:

Hey Will,
The original SSH shipped with the base system is actually a scaled down
version. Check out /usr/ports/security/openssh-portable. Compile the
above
port with option -DOPENSSH_OVERWRITE_BASE and also include
-DWITHOUT_KERBEROS if you do not need the Kerberos Authentication.
This will
overwrite the base SSH system with an OpenSSH version specifically
ported to
FreeBSD. Also I would like to know the contents of CFLAGS in
/etc/make.conf.
Make a note that after every "make world" you would have to clean and
reinstall the port with


make install -DOPENSSH_OVERWRITE_BASE -DWITHOUT_KERBEROS

Cheers!

Subhro

-----Original Message-----
From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of Will Prater
Sent: Sunday, January 04, 2004 2:20 AM
To: [EMAIL PROTECTED]
Subject: Re: sshd crashing server


On Jan 2, 2004, at 3:36 PM, Lowell Gilbert wrote:


Will Prater <[EMAIL PROTECTED]> writes:

List,

sshd seems to be crashing my server. I am looking for any help
regarding why this could be happening. I am running sshd version
OpenSSH_3.6.1. Here is the output from dmesg:

the machine crashed every time when running

#ipfw show
or
#dmesg -a

for example and will crash when part way through the listing. Any
ideas??

----
Fatal trap 12: page fault while in kernel mode
fault virtual address   = 0x0
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc023c52a
stack pointer           = 0x10:0xd9ff6bbc
frame pointer           = 0x10:0xd9ff6be4
code segment            = base 0x0, limit 0xfffff, type 0x1b
                         = DPL 0, pres 1, def32 1, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 394 (sshd)
interrupt mask          = net tty
trap number             = 12
panic: page fault

1) What version of FreeBSD?

4.9 RELEASE


2) How did you install that version of OpenSSH?

I have tried the one from the ports and the pre-installed version.



Thanks



--will


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to
"[EMAIL PROTECTED]"






--will







--will

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to