Greetings,

I have a D-Link DWL-G520 PCI card that I am trying to install, with less success than I would like.

I am using FreeBSD 5.2-RC2. I have been able to bring the card up manually with ifconfig for an Atheros chipset ("ifconfig ath0 inet 192.168.39.100 netmask 255.255.255.0") and doing so, I can see the .html setup screens for my router (D-Link Di-624 (192.168.39.1))--so there is a connection. However, there I am stopped. I cannot get past the wireless router to my other machines (hooked into a Linksys Cable/DSL router (192.168.38.1)) or the Internet in general. No http, no pings, nada.

I'm led to believe that the fault is with my setup of the wireless card. If I hook the machine into one of the wireless router's rj45 jacks, the connection is just fine. The wireless card also functioned without problems in a short-lived win98 install. So the card works, and the router setup seems to be good. That leaves the card setup within FreeBSD.

I am at a loss as to what to try next. I've tried DHCP, I've tried setting up a network interface via sysinstall after bringing up the ath0 whoozit with ifconfig (apparently the card is not detected at startup?)...

What am I missing?

Any suggestions? Relevant documentation you can direct me to? Direct solutions? :)


--G. Held -- End of line. _______________________________________________ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-questions To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to