Oops... you're right.  FreeBSD 4.9-RELEASE.  Never tried it with windows.
However, I've put this exact card into a different server (with only two
serial ports) and it is found as sio4 and works perfectly.

In the broken machine the boot message says what you have below, that it's
moving it to sio4, and I did make the devices (did the same things I did
for the machine that works) but still nothing.

For now I'll just use the other machine, but it's irksome...


> To start with you are very light with details about your
> environment, like what version of FBSD you are running and when you
> say the modem works, you failed to say if it worked in an FBSD
> system or MS/Windows system.
> For your info many of the PCI modems on the market are manufactured
> specially for MS/windows and are missing the onboard controller. The
> controller function is performed by the modem driver you have to
> load into MS/windows. If you have one of those winmodems but it back
> in your windows box where it belongs.
> Lets assume your modem has the onboard controller.
> Have you reviewed the boot log  /var/run/dmesg.boot file?
> It may be found as (unknown) in that case it may be an winmodem for
> sure, or you have installed FBSD on an pre Y2K PC and it's bio's are
> giving FBSD problems.
> Adding  device puc  to your kernel source and recompiling your
> kernel will fix this problem.
> The other condition is the your modem is found at boot time and is
> moved to sio4 which is really com5 which in not defined in the 4.x
> versions of FBSD.
>   sio0: <Zoom PCI Modem> port
> 0xe400-0xe407,0xe000-0xe0ff,0xdc00-0xdcff mem 0xe2000000-
>   sio0: moving to sio4
>   sio4: type 16550A
>    Sio4 is internal device cuaa4.
>    For some unknown reason this device is not in the device table
> for 4.x versions
>    You have to create it manually by doing the following commands.
>   cd /dev
>   ls -l /dev/cuaa4            shows as not found
>   sh MAKEDEV cuaa4            run script to make the device.
> MAKEDEV must be in caps.
>   ls -l /dev/cuaa4            now shows it's there
>       Device cuaa4 is the device you tell user ppp to use to connect with
> your PIC modem.
> If you are running 5.x version of FBSD then you do not have to
> makedev it auto in 5.x.
> -----Original Message-----
> [mailto:[EMAIL PROTECTED] Behalf Of Philip
> Hallstrom
> Sent: Monday, January 05, 2004 1:03 PM
> Subject: Installing PCI modem in machine with 4 serial ports (HELP!)
> Hi -
>         I've got a little computer that has four serial ports
> built-in to
> the motherboard.  I want to add a PCI modem (USR 5610B) and am
> having a
> devil of a time.  I know this modem works since I've used it (well,
> another one just like it) in another machine no problem.
> Here's the computer's board:
> http://www.orbitmicro.com/products/embedded%20boards/via/EBC-569.htm
> The last time I did this it just worked.  However, this bit from the
> Handbook has me concerned:
> --------------------------------------------------------------------
> ---
> These are the four serial ports referred to as COM1 through COM4 in
> the
> MS-DOS/Windows world.
>     Note: If you have an internal modem on COM4 and a serial port at
> COM2,
> you will have to change the IRQ of the modem to 2 (for obscure
> technical
> reasons, IRQ2 = IRQ 9) in order to access it from FreeBSD. If you
> have a
> multiport serial card, check the manual page for sio(4) for more
> information on the proper values for these lines. Some video cards
> (notably those based on S3 chips) use IO addresses in the form of
> 0x*2e8,
> and since many cheap serial cards do not fully decode the 16-bit IO
> address space, they clash with these cards making the COM4 port
> practically unavailable.
>     Each serial port is required to have a unique IRQ (unless you
> are
> using one of the multiport cards where shared interrupts are
> supported),
> so the default IRQs for COM3 and COM4 cannot be used.
> --------------------------------------------------------------------
> ---
> I rarely use modems, and am even less proficient at messing around
> with
> IRQ stuff.  What I'm concerned about is that it seems to say you can
> only
> have 4 serial ports (COM1 -> COM4) total... which means I'm kind of
> screwed.
> I've tried disabling all of the serial ports via the BIOS, but it
> doesn't
> help...
> If anyone out there has any light to shed on how to get this working
> I'd
> appreciate it.
> Thanks!
> -philip
> _______________________________________________
> [EMAIL PROTECTED] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to