Hi Everyone,
    I'm having difficulty getting my SCSI hard disks to preform
well.  I don't know what tools are available to help me diagnose
this issue, or if there are specific tweaks that I need to make.
Attached is the output from dmesg.

The reason why I say that performance is slow is that when I run
the following:

# dd if=/dev/zero of=/dev/da0 count=200 bs=128k
200+0 records in
200+0 records out
26214400 bytes transferred in 5.100589 secs (5139485 bytes/sec)

You can see that it doesn't transfer very fast.  If I do the
whole drive, I still get the same throughput.  It strikes me as
odd that an older ATA disk preforms better than the newer SCSI
disk.  I am under the impression that a standard run-of-the mill
ATA drive will do anywhere from 10-15 MB/s sequential transfer,
which is what I get when writing to an actual filesystem (with no

# mount
/dev/ad0s1a on / (ufs, local)
/dev/ad0s1f on /tmp (ufs, local, soft-updates)
/dev/ad0s1g on /usr (ufs, local, soft-updates)
/dev/ad0s1e on /var (ufs, local, soft-updates)
procfs on /proc (procfs, local)

# dd if=/dev/zero of=/temp.234233 count=200 bs=128k
200+0 records in
200+0 records out
26214400 bytes transferred in 2.437368 secs (10755208 bytes/sec)

And with soft-updates:

# dd if=/dev/zero of=/usr/temp.234233 count=200 bs=128k
200+0 records in
200+0 records out
26214400 bytes transferred in 2.759680 secs (9499072 bytes/sec)

I also had (meaning it is not currently attached) a different
SCSI drive attached on the bus, with the same results.  Has
anyone any tips for this from a FreeBSD point of view?

Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.8-RELEASE #0: Thu Apr  3 10:53:38 GMT 2003
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium II/Pentium II Xeon/Celeron (298.54-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x660  Stepping = 0
real memory  = 134217728 (131072K bytes)
avail memory = 125378560 (122440K bytes)
Preloaded elf kernel "kernel" at 0xc051d000.
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 9 entries at 0xc00ede10
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Intel 82443BX (440 BX) host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <Intel 82443BX (440 BX) host to PCI bridge> mem 0x44000000-0x47ffffff at device 
0.0 on pci0
pcib1: <Intel 82443BX (440 BX) PCI-PCI (AGP) bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <ATI Mach64-GD graphics accelerator> at 0.0 irq 11
fxp0: <Intel Pro 10/100B/100+ Ethernet> port 0x2400-0x241f mem 
0x40100000-0x401fffff,0x42000000-0x42000fff irq 11 at device 15.0 on pci0
fxp0: Ethernet address 00:08:c7:89:c4:28
inphy0: <i82555 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ahc0: <Adaptec 2940 Ultra SCSI adapter> port 0x2000-0x20ff mem 0x40200000-0x40200fff 
irq 11 at device 16.0 on pci0
aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs
isab0: <Intel 82371AB PCI to ISA bridge> at device 20.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 ATA33 controller> port 0x2440-0x244f at device 20.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0x2420-0x243f irq 11 at device 
20.2 on pci0
usb0: <Intel 82371AB/EB (PIIX4) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
chip0: <Intel 82371AB Power management controller> port 0xfc00-0xfc0f at device 20.3 
on pci0
orm0: <Option ROMs> at iomem 
0xc0000-0xc7fff,0xc8000-0xc97ff,0xc9800-0xd07ff,0xe0000-0xe7fff on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ad0: 3093MB <FUJITSU MPB3032ATU> [6286/16/63] at ata0-master UDMA33
Waiting 15 seconds for SCSI devices to settle
Mounting root from ufs:/dev/ad0s1a
da0 at ahc0 bus 0 target 0 lun 0
da0: <SEAGATE ST36530W 1444> Fixed Direct Access SCSI-2 device
da0: 40.000MB/s transfers (20.000MHz, offset 8, 16bit), Tagged Queueing Enabled
da0: 6208MB (12715920 512 byte sectors: 255H 63S/T 791C)
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to