Hi list,

I suppose, that the repeated messages on ttyv0 "swap_pager_getswapspace:
failed", "swap_pager: out of swap space", "/kernel: pid  7184 (cc1plus),
uid 0, was killed: out of swap space" and the error code of the failed
compilation of doxygen ""c++: Internal compiler error: program cc1plus got
fatal signal 9" exactly mean, what they say. :-)

In fact, it really is a little FreeBSD 4.8 box with P1-133, 64 meg RAM and
112 meg swap space. Not the racing machine, I know. But I had FreeBSD 4.7
before that 4.8-system on the same machine and never had this error, even
regarding the same port (gdal-1.1.8). This port installs a lot of
dependencies, one is doxygen.


-------------------------------------------------------------------------

gmake -f Makefile.libdoxycfg PERL=/usr/bin/perl all
gmake[2]: Entering directory
`/usr/ports/devel/doxygen/work/doxygen-1.3.3/src'
flex -PconfigYY -t config.l >config.cpp
c++ -c -O -pipe -D_THREAD_SAFE -Wall -W -I../qtools -o ../objects/config.o
confi
g.cpp
c++: Internal compiler error: program cc1plus got fatal signal 9
gmake[2]: *** [../objects/config.o] Error 1
{standard input}: Assembler messages:
{standard input}:14050: Warning: end of file not at end of a line; newline
inser
ted
gmake[2]: Leaving directory `/usr/ports/devel/doxygen/work/doxygen-1.3.3/src'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory `/usr/ports/devel/doxygen/work/doxygen-1.3.3/src'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/devel/doxygen
-------------------------------------------------------------------------





I then tried to install doxygen as package via sysinstall. That failed,
too and sysinstall tried to install an older version of doxygen (1.2.x)
than the port tree offers (1.3.3). See the follwing error message:

"Add of package freetype2-2.1.3_1 aborted, error code 1 Please check the
debug screen for more info."


freetype2 ist alread installed, but version 2.1.5_1!?


So, as it is three month ago, I installed that box and never did a cvsup
again (or something else), I decided to update the ports tree. Even that
failed, too:

Checkout port/www/p5-libapreq/pkg-descr
Updater failed: Cannot install
"/usr/ports/www/p5-libapreq/#cvs.cvxup-7326.13959" to
"/usr/ports/www/p5-libapreq/pkg-descr": Is a directory

Well, I also made "make index", but of course there are a lot of messages
that the "dependency list (is) incomplete". I shouldn't have done that,
should I?


That is where I am now. Can somebody give me some advice?!

Is it really to less swap space? I really never had that before on that
machine. How do I get doxygen installed? Is my port tree now broken? How
can I fix this?


Thanks in advance and sorry for the chaos,
Benjamin
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to