Hello Subhro,

thank you very much for your advices! I tried, what you've told me, but I
failed right at the beginning. May be you could comment some of my
problems/questions, that would surely help me for the next time.


> Hi Benjamin,
> I suspect that you have assigned too little swap space. As depicted in
the
> handbook, "The swap space should be *at least* 2 times the physical
memory
> present in the system. You should assign more swap space if the amount
of
> RAM is small"...which is your case. I think you should be assigning at
least
> 256M of swap space.


I just thought the disklabel default value would be fine and as I
previously wrote, I think, I did the same on the old 4.7-system.
It is strange, that I have 64meg of RAM, but 112meg instead of 128meg were
assigned as a default by disklabel for swap!?

Nevertheless I tried to increase swap-space, but I did my next mistake,
because I forgot to umount /data (ad0s1h) before deleting via fdisk. fdisk
complained, did something, but I don't know what.

Then, the the machine stopped booting with the following error-message:

--------------------------------------------------------------------------
/dev/ad0s1h: CANNOT READ: BLK 12759072
/dev/ad0s1h: UNEXPECTED INCONSISTENCY; RUN FSCK MANUALLY.

THE FOLLOWING FILE SYSTEM HAD AN UNEXPETED INCONSISTENCY:
/dev/ad0s1h (/data)

Automatic file system check failed...help!
Enter full pathname of shell or RETURN for /bin/sh:
--------------------------------------------------------------------------

Usually I know this error, if an entry in /etc/fstab is wrong. In this
case, I suppose, this partition wasn't formatted correctly!?


I pressed RETURN and found the shell. I could mount filesystems, great,
but I could not delete the /data entry in /etc/fstab, because / partition
was mounted read-only.

After that I tried single-user mode and Fix-it disk, but in both cases, I
even didn't have the most basic commands available:

mount
cd
ls
vi

I could do nothing. I suppose that the reason was, that I should have
supplied the full path to the command, because no PATH-environment is set
in case of using singel user mode or fixit.
Well, this idea came to late and I gave up and started a new FreeBSD 4.9
installation, with, I hope enough swap space!




> , but stops


> And regarding the port tree, you have damaged your
> port
> tree. I would recommend first CVSup the main source tree (however it is not
> necessary, but its nice to stay updated)

As this is such a slow machine, I would prefer not do to this at them
moment. Later I'll do.


>. Then delete the entire ports
> tree,
>
> rm -rf /usr/ports/*
>
> And then pull down the ports tree off the cvsup server. By the way, do copy

Will cvsup <portsupfile> do, even the ports tree is completely empty!? If
so, that's cool and easy. Isn't there somewhere the port-db, which also
have to be made new? I thought the db is located in /var/db/pkg.



> /usr/ports/distfiles to some other place before running the rm command.
>That
> will save you quite some time.

Good idea.

> You should be back in business then. Let us
> know if that worked out


Thanks again for your help. It would be really nice, to have some little
comments on my mistakes!


Regards,
Benjamin

>
> Regards
> Subhro
>
> Subhro Sankha Kar
> Indian Institute of Information Technology
> Block AQ-13/1, Sector V
> Salt Lake City
> PIN 700091
> India
>
> -----Original Message-----
> From: [EMAIL PROTECTED]
> [mailto:[EMAIL PROTECTED] On Behalf Of
[EMAIL PROTECTED]
> Sent: Wednesday, January 07, 2004 8:17 PM
> To: [EMAIL PROTECTED]
> Subject: swap_pager: out of swap space --> doxygen installation fails
>
> Hi list,
>
> I suppose, that the repeated messages on ttyv0 "swap_pager_getswapspace:
failed", "swap_pager: out of swap space", "/kernel: pid  7184 (cc1plus),
uid 0, was killed: out of swap space" and the error code of the failed
compilation of doxygen ""c++: Internal compiler error: program cc1plus
got
> fatal signal 9" exactly mean, what they say. :-)
>
> In fact, it really is a little FreeBSD 4.8 box with P1-133, 64 meg RAM
and
> 112 meg swap space. Not the racing machine, I know. But I had FreeBSD
4.7
> before that 4.8-system on the same machine and never had this error,
even
> regarding the same port (gdal-1.1.8). This port installs a lot of
dependencies, one is doxygen.
>
>
> -------------------------------------------------------------------------
>
> gmake -f Makefile.libdoxycfg PERL=/usr/bin/perl all
> gmake[2]: Entering directory
> `/usr/ports/devel/doxygen/work/doxygen-1.3.3/src'
> flex -PconfigYY -t config.l >config.cpp
> c++ -c -O -pipe -D_THREAD_SAFE -Wall -W -I../qtools -o
../objects/config.o
> confi
> g.cpp
> c++: Internal compiler error: program cc1plus got fatal signal 9
gmake[2]: *** [../objects/config.o] Error 1
> {standard input}: Assembler messages:
> {standard input}:14050: Warning: end of file not at end of a line;
newline
> inser
> ted
> gmake[2]: Leaving directory
> `/usr/ports/devel/doxygen/work/doxygen-1.3.3/src'
> gmake[1]: *** [all] Error 2
> gmake[1]: Leaving directory
> `/usr/ports/devel/doxygen/work/doxygen-1.3.3/src'
> gmake: *** [all] Error 2
> *** Error code 2
>
> Stop in /usr/ports/devel/doxygen
> -------------------------------------------------------------------------
>
>
>
>
>
> I then tried to install doxygen as package via sysinstall. That failed,
too and sysinstall tried to install an older version of doxygen (1.2.x)
than the port tree offers (1.3.3). See the follwing error message:
>
> "Add of package freetype2-2.1.3_1 aborted, error code 1 Please check the
debug screen for more info."
>
>
> freetype2 ist alread installed, but version 2.1.5_1!?
>
>
> So, as it is three month ago, I installed that box and never did a cvsup
again (or something else), I decided to update the ports tree. Even that
failed, too:
>
> Checkout port/www/p5-libapreq/pkg-descr
> Updater failed: Cannot install
> "/usr/ports/www/p5-libapreq/#cvs.cvxup-7326.13959" to
> "/usr/ports/www/p5-libapreq/pkg-descr": Is a directory
>
> Well, I also made "make index", but of course there are a lot of
messages
> that the "dependency list (is) incomplete". I shouldn't have done that,
should I?
>
>
> That is where I am now. Can somebody give me some advice?!
>
> Is it really to less swap space? I really never had that before on that
machine. How do I get doxygen installed? Is my port tree now broken? How
can I fix this?
>
>
> Thanks in advance and sorry for the chaos,
> Benjamin
> _______________________________________________
> [EMAIL PROTECTED] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "[EMAIL PROTECTED]"
>
>
>
>
>
>



_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to