On Sat, Jan 10, 2004 at 08:54:39PM +1000, Q wrote:
> On Sat, 2004-01-10 at 20:36, Loren M. Lang wrote:
> > I was trying to run a Linux program called [EMAIL PROTECTED] in FreeBSD, but
> > it doesn't seem to want to load.  I have a version compiled for
> > glibc 2.2 I believe, but when I run it in bsd, I get the error message:
> > 
> > ELF binary type "0" not known.
> > Abort trap
> I have never tried this particular program, so I can't say if it will
> work for sure, but I see no reason why it shouldn't. Try doing an
> 'brandelf -t Linux <file>' and run it again. This will let FreeBSD know
> that it's a Linux binary.

It worked! 

I'm assuming this actually modifies the elf file, is it still compatible
with linux, and is this a common problem or just for certain rare

> > That was using version 3.x of [EMAIL PROTECTED]  They also have a glibc 2.3 
> > version,
> > but that also fails:
> > 
> > ./FAH3Console-LinuxB.exe: /lib/libc.so.6: version `GLIBC_2.3' not found
> > (required by ./FAH3Console-LinuxB.exe)
> If you need glibc 2.3 then you need to install the
> 'emulation/linux_base-8' port, this is the equivalent to a RedHat 8 base
> system, rather than the RedHat 7 base you have installed now.

I'll try it.

> Seeya...Q
> !DSPAM:3fffdb41195678470827837!

I sense much NT in you.
NT leads to Bluescreen.
Bluescreen leads to downtime.
Downtime leads to suffering.
NT is the path to the darkside.
Powerful Unix is.

Public Key: ftp://ftp.tallye.com/pub/lorenl_pubkey.asc
Fingerprint: B3B9 D669 69C9 09EC 1BCD  835A FAF3 7A46 E4A3 280C

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to