hello all,

i am trying to build the libmap.conf feature under 4.9 in order to install
the linuxpluginwrapper port.  hopefully someone here will know what to
suggest for the error message i am getting.

----------------------------------------------------
port error msg under vanilla 4.9
----------------------------------------------------

Please enable libmap.conf(5) feature for rtld(1).
4-stable user:
        You can get a following patch.
        http://people.FreeBSD.org/~nork/libmap_4stable.diff
        Please apply on /usr/src and make install on
        /usr/src/libexec/rtld-elf.

----------------------------------------------------
download the patch and apply
----------------------------------------------------

/usr/src# patch < /foo/libmap_4stable.diff
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
     [snip]
Patching file libexec/rtld-elf/rtld.c using Plan A...
Hunk #1 succeeded at 52.
Hunk #2 succeeded at 132.
Hunk #3 succeeded at 295.
Hunk #4 succeeded at 369.
Hunk #5 succeeded at 797.
Hunk #6 succeeded at 1444.
done

----------------------------------------------------
here is where problem occurs
----------------------------------------------------

/usr/src/libexec/rtld-elf# make install
install -s -o root -g wheel -m 555  -fschg -C -b ld-elf.so.1 /usr/libexec
install: ld-elf.so.1: No such file or directory
*** Error code 71

----------------------------------------------------

i have also tried to 'make buildworld' with the patched source, but it
fails.  however, the failure doesn't seem to be tied directly to the
rtld-elf piece (at least from what i can see).

any suggestions would be very much appreciated.


thanks,
epi
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to