On Tue, Jan 13, 2004 at 01:37:25AM -0500, Michael A. Alestock wrote:
> I get numerous errors while trying to, "portsdb -Uu", 'portversion -l "<",
> and  "portupgrade -arR".  I don't get any kind of prompt to change anything.
> How would I go about fixing these errors so that I can upgrade my ports to the latest
> version(s)??  Here's a snippet from the PORTUPGRADE I did, but it stopped
> after coming up in error....
> 
> Stop in /usr/ports/x11-servers/XFree86-4-FontServer.
> ** Command failed [exit code 1]: /usr/bin/script -qa
> /tmp/portupgrade72647.10 make
> ** Fix the problem and try again.
> --->  Skipping 'x11/XFree86-4' (XFree86-4.3.0,1) because
> 'x11-servers/XFree86-4-FontServer' (XFree86-FontServer-4.3.0) failed
> ** The following packages were not installed or upgraded (*:skipped /
> !:failed)
>         ! dns/noip (noip-1.6)   (port directory error)
>         ! www/mod_php5 (mod_php5-5.0.0.a3_2,1)  (configure error)


                I may be able to speak to the above 'configure'
                err.  Some of my hosts are not running 4.7 or 4.8,
                but 4.[78]-PRERELEASE.  In at least one port, the
                pre-processor checks for the version number; 
                if < 4.7; if > 4.8...  

                Until I move up to 4.9, each time I upgrade, 
                I have do hack the src a wee bit. You might 
                grep -r the mod_php5 src and see.

                gary


-- 
   Gary Kline     [EMAIL PROTECTED]   www.thought.org     Public service Unix

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to