I'm running 5.1-RELEASE.  For several weeks, when doing a portupgrade, atk
won't upgrade.

When I run portupgrade -a, I get the following at the end of the run:

[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 200 packages
found (-0 +1) . done]
--->  Skipping 'x11-toolkits/gtk20' (gtk-2.2.4_1) because 'devel/atk'
(atk-1.4.1) failed
--->  Skipping 'devel/libglade2' (libglade2-2.0.1_1) because
'x11-toolkits/gtk20' (gtk-2.2.4_1) failed
--->  Skipping 'editors/AbiWord2' (AbiWord2-2.0.1) because
'devel/libglade2' (libglade2-2.0.1_1) failed
--->  Skipping 'www/plugger' (plugger-4.0_3) because 'editors/AbiWord2'
(AbiWord2-2.0.1) failed
--->  Skipping 'textproc/gtkspell2' (gtkspell2-2.0.4) because
'x11-toolkits/gtk20' (gtk-2.2.4_1) failed
--->  Skipping 'net/gaim' (gaim-0.71_4) because 'textproc/gtkspell2'
(gtkspell2-2.0.4) failed
** The following packages were not installed or upgraded (*:skipped /
        ! devel/atk (atk-1.4.1) (checksum mismatch)
        * x11-toolkits/gtk20 (gtk-2.2.4_1)
        * devel/libglade2 (libglade2-2.0.1_1)
        * editors/AbiWord2 (AbiWord2-2.0.1)
        * www/plugger (plugger-4.0_3)
        * textproc/gtkspell2 (gtkspell2-2.0.4)
        * net/gaim (gaim-0.71_4)

Scrolling back and looking at the attempted upgrade of atk shows:

>> Checksum mismatch for gnome2/atk-1.4.1.tar.bz2.
===>  Refetch for 1 more times files: gnome2/atk-1.4.1.tar.bz2
>> atk-1.4.1.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/gnome2.
>> Attempting to fetch from
fetch: atk-1.4.1.tar.bz2: local modification time does not match remote

It goes on to try many different mirror sites, each one resulting in this
modification time error.

This has been the case for several weeks so I assume it's a problem with
my installation and not with the port itself.  Presumably if everyone was
having this problem someone would have fixed it.

Any ideas as to where I should start looking to fix this?  It's annoying
since there are about a half a dozen other ports that won't upgrade due to
a dependency to atk.

Thanks in advance,
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to