I am trying to configure a secure pppoe server.So far it works perfectly with Windows 
clients authenticating with MSChapv2. However, if MPPE is negotiated, the client 
receives only about 1/4th(30-40 kbytes/s) of the bandwidth available while 
Download seem 'leapy' : it starts with high speed , then for a second or two it stops 
completely then it bursts again. I'm not quite sure why this happens, but everything 
goes back to normal when mppe is turned off. I assume that this is due to the 
re-initialised key on every 256th packet. Anybody seen that? 
I tried different key lengths for the mppe but nothing changed. I haven't tried the 
stateless encryption though, beacuse the clients reject it.

Here are the details :

 allow users
 enable chap
 enable pap
 enable mschap
 enable mschapv2
 enable mppe
 set mppe 40 stateful
 disable deflate pred1 utmp vjcomp ipv6cp ccp
 deny deflate pred1 utmp vjcomp ipv6cp ccp
 allow mode direct
 set mru 1492
 set mtu 1492
 set speed sync
set ifaddr
set log connect command chap lcp error alert warning

Emil Filipov
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to