On Saturday 17 January 2004 15:24, Adam Olsen wrote:
> Ok,
> The file can be found at http://linuxhelp.homeunix.com/xfree.log and my
> XF86Config at http://linuxhelp.homeunix.com/XF86Config

You have the generic NVIDIA driver specified, this could be the problem.
Try to run the following commands:

        XFree86 -configure
        XFree86 -xf86config ~/XF86Config.new

Do you still get the error when switching to VT?
If no, you will probably have to reconfigure X using the ~/XF86Config.new as 
the basis, but the problem is solved.
If yes, send the file /var/log/XFree86.0.log.

> Thanks,
> Adam Olsen
> Daniela wrote:
> >On Thursday 15 January 2004 21:35, Adam Olsen wrote:
> >>Daniela,
> >>
> >>When I press ctrl+alt+F1, I am on the virtual console, but I cannot see
> >>it because I'm getting the mode out of range error.  X does not
> >>terminate - and if I press ctrl+alt+F9, I can get back to X just fine -
> >>no more out of range error on the monitor.
> >>
> >>I can be on the virtual console until I startx, and which point if I
> >>switch back to a virtual console or exit X I get the mode out of range
> >>error.
> >>
> >>So basically, after I startx, something happens to the virtual console
> >>that makes it so that if I go back to it I get the mode out of range
> >> error.
> >
> >OK, do the following: use the command "startx >& somefile" and send me the
> >file it produces. This will hopefully tell us what the problem is.
> >
> >>Thanks,
> >>
> >>Adam Olsen
> >>
> >>Daniela wrote:
> >>>On Thursday 15 January 2004 20:00, Adam Olsen wrote:
> >>>>Daniela,
> >>>>
> >>>>Ok - Everything works perfectly in X.  When I switch to the VT, I get a
> >>>>mode out of range error.  I can switch back to X just fine.  Just the
> >>>> VT has this problem.
> >>>
> >>>OK, when you press, say, ctrl+alt+F1 to switch to the VT, are you still
> >>>in X or at the console? Is the error message at the console or on the VT
> >>>from where you entered startx? Does X terminate?
> >>>
> >>>>I never get the wavy text while in X.  If by chance I am able to switch
> >>>>to the VT for some reason without getting the mode out of range error,
> >>>>all the text is waving around.  This has not happened in FreeBSD 5.2,
> >>>>but I did see it a few times in 4.8 (I don't know if I'll be able to
> >>>>reproduce it).
> >>>
> >>>If you switch back to X when you get the wavy text, is everything OK
> >>>there? Can you start X from inside a debugger? What do you have in your
> >>>XF86Config?
> >>>
> >>>I'll go to sleep now, good night.
> >>>
> >>>>Thanks,
> >>>>
> >>>>Adam Olsen
> >>>>
> >>>>Daniela wrote:
> >>>>>On Thursday 15 January 2004 19:29, Adam Olsen wrote:
> >>>>>>Daniela,
> >>>>>>
> >>>>>>I see it when I switch to a virtual console only.  When I switch back
> >>>>>>to X, I'm ok again.  Also, if I exit X, I get it the error, but I can
> >>>>>>blindly startx again.
> >>>>>
> >>>>>I don't quite understand what you mean. I thought you can't switch
> >>>>> back to VT?
> >>>>>
> >>>>>>At one point in FreeBSD 4.8 I could switch to the virtual console,
> >>>>>> but everything was wavy - text was moving around (it was really
> >>>>>> weird).
> >>>>>
> >>>>>Could you describe this a bit more? I'm often seeing text moving
> >>>>> around, and weird colorful stripes on the screen when I switch to X.
> >>>>> Viewing a specific page in Mozilla triggers this. Unfortunately, I
> >>>>> can't just open the debugger and see what's going on at this time,
> >>>>> because I can hardly see anything on the screen.
> >>>>>When you're able to reproduce it, then have a look at the on-screen
> >>>>> menu of your monitor and check the frequencies, they're probably way
> >>>>> too high.
> >>>>>
> >>>>>>Thanks,
> >>>>>>
> >>>>>>Adam Olsen
> >>>>>>
> >>>>>>Daniela wrote:
> >>>>>>>On Thursday 15 January 2004 17:06, Adam Olsen wrote:
> >>>>>>>>Hello,
> >>>>>>>>
> >>>>>>>>I'm using FreeBSD 5.2-RELEASE and have installed the latest nvidia
> >>>>>>>>drivers available.  Everything works ok _except_ once I load X I
> >>>>>>>>cannot switch back to the virtual console.  I get a "mode out of
> >>>>>>>>range" error. I had this problem with FreeBSD 4.8 as well.
> >>>>>>>
> >>>>>>>This isn't necessarily nvidia-specific, I have this too with ATI.
> >>>>>>>Where and when exactly do you see the "mode out of range" error?
> >>>>>>>
> >>>>>>>My best guess would be that this is an XFree86 bug.
> >>>>>>>
> >>>>>>>Daniela
> >
> >_______________________________________________
> >[EMAIL PROTECTED] mailing list
> >http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> >To unsubscribe, send any mail to

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to