On Wed, Jan 21, 2004 at 08:59:32PM -0500, Eric wrote:
> hello...
> i have been trying (for many moons now) to create a filesystem larger than
> 1TB. I've had a variety of RAID controllers in my boxes, and I have 250GB
> drives, so it adds up quick. I've also tried doing this with vinum, but
> that fails too.
> i've searched for help on this topic, and i've found lots of info, but
> nothing substantial. I've read everything from it being a sysinstall
> issue, to needing new versions of the CLI tools (newfs, dd, disklabel), to
> newfs using the wrong variable type to store fssize, to having to update
> to fbsd 5.x to use UFS2. Other reports say it's a softlimit imposed
> somewhere, some say to make the frag size in newfs to 1024B for a 2TB max
> volume, it has to be dedicated, it has to be non-dedicated... the list of
> suggestions goes on and on.

I've got several boxes running 5.x that have >1TB file systems.  The
only issue I ran into (other then the insane fsck times) is the fact
that sysinstall's fdisk blows up somewhere over 1TB.  The workaround if
you have to install on a large array is to use sysinstall's fdisk to
create a slice large enough to hold the OS and leave the rest of the
disk unpartitioned.  You can then add a slice for the rest of the disk
later since fdisk works with larger volumes.  Default newfs parameters
in 5.x seem to work OK on a 1.7TB array.  With disks that large, it's
probably wise to think a bit more then usual about the average file size
so you can choose your parameters correctly.

I'm almost certain you will have no luck in 4.x.

-- Brooks

Any statement of the form "X is the one, true Y" is FALSE.
PGP fingerprint 655D 519C 26A7 82E7 2529  9BF0 5D8E 8BE9 F238 1AD4

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to