Thanks for your thoughtful and helpful reply.  I should have given more 
technical details.

I already tried (with both 4.9 and 5.1) letting the FreeBSD install proceed 
with fdisk's  geometry value assumptions, and what I always get is a 
non-bootable hard drive that gives the "Missing operating system" error at 
boot.

The hard drive is IDE, not SCSI.  It is a Maxtor UltraMax 40GB ATA/100 drive 
purchased shy of two years ago.  The "physical geometry" reported by Maxtor 
in the specs for the drive is different from the geometry my BIOS reports 
that it has auto-detected and is using to address the drive.  And both of 
*those* geometries are different from the one that fdisk keeps trying to 
assume.

I've already read all the FAQs, handbooks, and support sites I could find 
regarding FreeBSD and disk geometry.  None of them have contained any 
information specific to IDE drives (they all seem SCSI-centric), and none of 
them have clearly explained all the background context about how drive 
geometries work.  I guess there is a "physical geometry" provided by the 
drive manufacturer, and then different geometries (all of which may be 
valid) your BIOS might use to address the drive depending on the mode it is 
using (LBA, etc).  As far as I can tell, the geometry values a user is 
supposed to feed to fdisk are the values that the BIOS reports that it is 
using to address the drive, but I'm not even sure if that is correct because 
the documentation is so impenetrable.  And of course many users are running 
into this issue where the drive geometries reported and used by their BIOS 
are simply rejected by fdisk as "invalid" whenever they try to enter them 
into fdisk, which makes no sense to me.



----- Original Message ----- 
From: "Jerry McAllister" <[EMAIL PROTECTED]>
To: "Keith Kelly" <[EMAIL PROTECTED]>
Cc: "freebsd-questions" <[EMAIL PROTECTED]>; 
<[EMAIL PROTECTED]>
Sent: Thursday, January 22, 2004 12:44 PM
Subject: Re: FDisk won't detect or accept correct disk geometry from BIOS


> >
> > Please see this page:
> > http://lantech.geekvenue.net/chucktips/jason/chuck/1044789670/index_html
> >
> > This is exactly the problem I am having now whenever I try to install 
> > either
> > FreeBSD 4.9 or 5.1.  Clearly, a lot of other users out there are having 
> > this
> > problem too.  FDisk absolutely refuses to accept the correct geometry 
> > values
> > (the ones my BIOS tells me it is using to address the disk), instead
> > insisting on using some values that are not even close to correct.  Then
> > after installation completes and I try to boot, I get a "missing 
> > operating
> > system" message, which is no surprise given that the disk was addressed 
> > by
> > the installer using the wrong geometry settings.
>
> Of about 100 to 110 FreeBSD systems we have up and going, I have never
> had the fdisk reported geometry match the BIOS reported information
> but I have never had a system fail to install and boot by just ignoring
> the whole issue and letting it (sysinstall, fdisk, etc) do its own thing
> as long as I didn't try to tinker with the geometry.  This has been with
> both SCSI and IDE disks, but mostly SCSI and almost entirely on mainstream
> hardware such as what comes with Dell, Compaq, etc, not homebuilts.
> The FreeBSD versions have been most of 3.xx through most of 4.xx. I
> haven't tried any 5.xx yet but the person in the box (cubicle) next to
> me has 5.1 going and sees the same thing.
>
> There have been lots of things written about this. I don't know which
> ones apply in your case.  But, the geometries on recent disks and
> recent versions of software (recent = in the last 6 or 7 years) are
> all "virtual" as far as I can see.    So, just try letting it fly
> and without trying to tinker or reconcile what appears to be a conflict.
>
> ////jerry 
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to