I've tried to update gettext in the ports collection, and a problem has
turned up.  As described to me by Joe Marcus Clarke, portupgrade will fail
because ports/devel/gettext (the new version which no ports use yet) is in
conflict with ports/devel/gettext-old (the previous version which I set
the ports to depend upon).

I believe that a line

        HOLD_PKGS = ['gettext-*']

in /usr/local/etc/pkgtools.conf may prevent portupgrade (but not
necessarily portversion) from trying to upgrade gettext.  Alternatively,
I've prepared a patch which bumps the libintl version and PORTREVISIONs of
ports that use gettext, so they depend on the new version.  It needs
testing and review.  It's at
<URL:http://people.freebsd.org/~trevor/ports/gettext-dependencies.diff>.

The updated gettext port may be temporarily "moved" to gettext-new and
ports/devel/gettext returned to version 0.12.1 which we've been using for
awhile.  Also, the new gettext port ought to be updated to 0.13.1.  I've
started work on that but I have to leave the computer now.
-- 
Trevor Johnson
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to