Shaun Friedle wrote:

I am very new to FreeBSD, but I'm trying to learn how to use it. This is made very 
difficult by not having a mouse.

I have tried searching on Google for a few hours, but haven't fixed the problem yet. Anyway, here it is:

My mouse is a "Logitech Cordless Desktop iTouch" optical USB mouse.

Hmmmm - I can remember some people reporting problems with these mice - but I had one that worked flawlessly.

/dev/ums0 does exist.

If I try to set up the mouse deamon in /stand/sysinstall the cursor will not move when set to Auto (or any other protocol).

If I do "moused -p /dev/ums0" I get "moused: unable to open /dev/ums0: Device busy".

That's becuase there should already be a moused running. usbd will start a new moused when it discovers a mouse connected.

Do a 'ps ax|grep moused' and see if moused is already running

dmesg finds everything alright:
ums0: Logitech USB Receiver, rev 1.10/13.10, addr 2, iclass 3/1
ums0: 5 buttons and Z dir.

When I try to use X everything is OK, but I just can't mouse the cursor.

Then in your X config you should be able to use /dev/sysmouse

Hope that gets you up and running!


P.S. There's a mailing list for UK FreeBSD users - have a look at - it can go pretty quiet but is good for UK-related chat ;)

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to