I'm currently using fetchmail to retrieve my email from my ISP. It works
wonderfully, especially in combination with procmail and SpamAssassin --
except for one little problem that I'd like to verify is a bug here
before sending a possibly spurious bug report. It seems that fetchmail
truncates all messages to around 77 kB or so. It sees the message as
more than 77 kB (for example, one such message comes up as 975525
octets.). It just can't deal with it. Here's what my .fetchmailrc looks 

== cut here ==
set daemon 600
set syslog
poll my.mail.server proto pop3 pass 'pass' ssl limit 0
fetchsizelimit 0
== cut here=

I've tried cutting procmail + SpamAssassin out of the process, and it
still truncates the message, this time sending to /var/mail/apeiron
rather than where I've told procmail to send it. I've tried manually
retrieving the email with mutt, saving it on disk, and viewing it with
Evolution versus having procmail fetch it, then viewing it with
Evolution. The former works, the latter doesn't.

I'm running fetchmail as /usr/local/bin/fetchmail -v -v from cron with
the @reboot qualifier.

I've RTFM'd and looked around for anything that would cause such an
arbitrary limit, and can't find anything.

It seems rather odd that such a limit would be arbitrarily imposed on
messages, and I'm hesitant to label it as a bug being that fetchmail is
so widely used. 

I abhor a system designed for the "user", if that word is a coded
pejorative meaning "stupid and unsophisticated".  -- Ken Thompson
Please CC me in all replies, even if I'm on the relevant list(s).

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to