On Sunday 01 February 2004 00:54, Jeff Elkins wrote:
> On Saturday 31 January 2004 6:35 pm, Melvyn Sopacua wrote:
> >On Saturday 31 January 2004 18:54, Jeff Elkins wrote:
> >> > > I _can_ mount cds using the /dev/acd* devices, while using the
> >> > > /dev/cd* devices for writing.  Is this the way atapi cdrws are
> >> > > supposed to work under freebsd?
> >> >
> >> > So, is cam compiled into the kernel? Do you have the xpt SCSI driver?
> >> > If cam is configured correctly, there should be mentioning of cd0
> >> > in /var/run/dmesg.boot and the cd's should be listed via:
> >> >
> >> > camcontrol devlist
> >>
> >> kathix# camcontrol devlist
> >> <DMI MultiFlash 3.00>              at scbus0 target 0 lun 0 (pass0,da0)
> >> <DMI MultiFlash 3.00>              at scbus0 target 0 lun 1 (pass1,da1)
> >> <DMI MultiFlash 3.00>              at scbus0 target 0 lun 2 (pass2,da2)
> >> <DMI MultiFlash 3.00>              at scbus0 target 0 lun 3 (pass3,da3)
> >> <SEAGATE ST15230N 0638>            at scbus1 target 0 lun 0 (pass4,da4)
> >> <PLEXTOR DVDR   PX-708A 1.03>      at scbus3 target 0 lun 0 (pass5,cd0)
> >> <TOSHIBA CD-ROM XM-6202B 1110>     at scbus3 target 1 lun 0 (pass6,cd1)
> >>
> >>
> >> cd0 at ata1 bus 0 target 0 lun 0
> >> cd0: <PLEXTOR DVDR   PX-708A 1.03> Removable CD-ROM SCSI-0 device
> >> cd0: 16.000MB/s transfers
> >>
> >> cd1 at ata1 bus 0 target 1 lun 0
> >> cd1: <TOSHIBA CD-ROM XM-6202B 1110> Removable CD-ROM SCSI-0 device
> >> cd1: 16.000MB/s transfers
> >
> >Try getting rid of the DMI devices. As you can see above, the cd's claim
> > bus0, while cam puts them on bus 3. Still a chance that the seagate
> > overrides them though.
> >
> >If:
> >cdrecord dev=3,0,0 yourfiles.iso
> >
> >works correctly, you might want to follow this up to -current or
> > -hardware.
>
> Thanks.
>
> All recording functions work, both with cdrecord and growisofs.  The only
> issue is being unable to mount with /dev/cd0, /dev/cd1. I realise that I'm
> in uncharted waters with 5.2, and I appreciate the reply.

Does cdrecord work with dev=/dev/cd0 also?
You did fixate those cd's (shouldn't give a "device not configured", but I/O 
error if you didn't, but just to make sure).
-- 
Melvyn

=======================================================
FreeBSD sarevok.webteckies.org 5.2-CURRENT FreeBSD 5.2-CURRENT #0: Wed Jan 28 
18:01:18 CET 2004     
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/SAREVOK_NOAPM_NODEBUG  
i386
=======================================================

Attachment: pgp00000.pgp
Description: signature

Reply via email to