Krikket wrote:

On Sun, 1 Feb 2004, Roop Nanuwa wrote:

Krikket wrote:

I've done a brand-new install of FreeBSD (4.9), and am a fresh user to
this flavor of *nix.

Welcome, we hope you enjoy your stay :).

Thank you!

The install went more or less without a hitch.  For some reason ldap (part
of the default package selection) didn't want to install.

Could you be a bit more specific? What happened during the install? Did
it give you any
error messages?

A generic compile error message, nothing specific. And unfortunately, I didn't take notes. (No, I wasn't expecting help with troubleshooting that point, it was said more in the way of a commentary than anything else. I figured that when I got to the point of needing it, I could always install it at a later time, and if needed ask questions then.)

To test things out, I tried installing mozilla. It failed due to a
dependancy, so I checked out the website to see what was available, found
a version that was there, adn installed it.

How are you installing mozilla? There shouldn't be any dependency
problems in either of the two main ways to install packages on FreeBSD.
Whether you install via the ports tree or through the package system all
the dependencies should be handled for you. I think the reason that
you're having dependency issues is because you're attempting to install
binaries that you've downloaded that aren't packaged for FreeBSD

I attempted to do a "pkg_add -r mozilla". After checking the on-line database of software at, I know I tried some versons of the command lile "... -r linux-mozilla" and sometimes with version numbers. I forget the exact one that did work.

But when I type "mozilla" to start the program, it's not found.  (Nor was
it added to the KDE Menu.)
I was able to do a "pkg_add -r cvsup" on the first try.  But I ended up
with the same problem -- not being able to find the package once it was
installed.  Needless to say, I can't add any ports as a result.

Which shell are you running? You might have to run 'rehash' to refresh
your shell's cache of available programs. Logging in/out would do the
same but running 'rehash' is simpler/quicker.

bash. I'll give that a shot. I'm not at home at the moment, and for some reason ssh doesn't want to allow me to login.

For bash, you'll want to do a 'hash -r' instead of rehash....


(I get a login prompt, but it's not accepting the correct password for either myself or the root accounts. Even after I called home and had the roommate reboot the system, just in case something flakey got into memory. I'm thinking it may be time to pull out the rubber chicken.)


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to