On Wed, 2004-02-04 at 14:31, stan wrote:
> I have a system that I have removed all teh non English language port
> directories, and I run a cvsup _with_ a refuse file for these. Then I did a
> portdb -Uu. This resulted in a fair number of complaints, but when I ran
> portupgrade -aRr it hapilly took of running.
> Granted this sytem only has 19 ports installed. But it seems to work. Am I
> missing somehting hrere?

Nope. I've been doing that too. I have non-english and unused ports
commented out in my ports-supfile (ports-all commented out and
individual ports are in), and also listed non-language ports in refuse.
portupgrade runs fine. portdb complaints with a ton of error messages
about dependencies missing etc, but all is well.

The only gotcha I encountered is when new ports branches are added (i.e.
port-dns). Since I list specific ports in my supfile, new ports are not
caught automatically, which means the supfile needs occasional
maintenance. That's about it. And you're right, it's a space saver on
small drives :)


Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to