On Mon, Feb 09, 2004 at 12:54:06PM +0100, Stefan Moro wrote:
> I'm trying to setup mysql40. I installed it from the ports via the
> mysql40-server port. The installation went just fine. Afetr the
> installation I was trying to set the mysql root-users password with
> mysqladmin -u root password 'new-password'

This sound correct.

> when i tried that I got the following message:
> mysqladmin: connect to server at 'localhost' failed
> error: 'Access denied for user: '[EMAIL PROTECTED]' (Using password: NO)'

Have you tried actually connecting to mysql without a password?  IIRC
when mysql is first installed (been a while now :P), the initial root
password is blank.

Try just typing 'mysql' - if you get to the 'mysql>' prompt successfully
then no password has been set.  I'm thinking though that if you're
getting that error then a password must have been set somehow...

If you really can't figure out how to get in there's a guide to
resetting the root mysql password here:


Good luck :P

Jez Hancock
 - System Administrator / PHP Developer

http://jez.hancock-family.com/  - Another FreeBSD Diary
http://ipfwstats.sf.net/        - ipfw peruser traffic logging
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to