Well, it worked mostly. I've got the partition table back and reinstalled boot0, but I must be confused about the later boot stages, because I can't get the partition I want to boot properly. I can boot from ad0s1a, but I want to boot from ad0s2a. I can mount ad0s1a and ad0s2a as well as ad0s3{d,e,f}, and everything seems to be in tact. In the bootloader, when I hit F2 to boot ad0s2a it just beeps at me. I tried to use 'bsdlabel -B /dev/ad0s2', but I must have done something wrong, because it didn't work. I also tried 'bsdlabel -B -b /current/boot/boot /dev/ad0s2' where /dev/ad0s2a is mounted on /current to no avail. What do I need to do?
Thanks some more,
--
Evan Dower
Undergraduate, Computer Science
University of Washington
Public key: http://students.washington.edu/evantd/pgp-pub-key.txt
Key fingerprint = D321 FA24 4BDA F82D 53A9 5B27 7D15 5A4F 033F 887D





From: Dejan Lesjak <[EMAIL PROTECTED]>
To: Evan Dower <[EMAIL PROTECTED]>
CC: [EMAIL PROTECTED]
Subject: Re: Recovering Damaged Partition Table
Date: Mon, 16 Feb 2004 04:44:32 +0100

Evan Dower wrote:

> So, the other day I was ripping some CDs...
>
> Upon restart, there was a message that ad0 had an unrecoverable error
> (media changed). It's a hard disk. I didn't notice any gnomes breaking
> into my computer and changing it on me. No matter. It won't boot. I
> installed FreeBSD on an empty partition of another disk, which is how I
> got to where I am now. Naturally, I have no backups.
>
> My plan is to reconstruct the partition table and then all should be fine.
> I've determined that my files seem to be in tact using 'strings /dev/ad0 |
> less'. It even looks like part of the partition table remains.
>


Hello,
You can try with this utility:
http://www.stud.uni-hannover.de/user/76201/gpart/
which is also included on knoppix live-cd
(http://www.knoppix.org/)
I just saved two NTFS partitions with it, so I hope this helps...

Dejan

_________________________________________________________________
Check out the great features of the new MSN 9 Dial-up, with the MSN Dial-up Accelerator. http://click.atdmt.com/AVE/go/onm00200361ave/direct/01/


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to