On Monday 16 February 2004 11:10 am, Marty Landman wrote:
> Any advice on what to do here?
>
> # cd ../../mail/fetchmail
> # make build && make install && rehash && which fetchmail
>
>  >> fetchmail-6.2.0.tar.gz doesn't seem to exist in
>  >> /usr/ports/distfiles/. Attempting to fetch from
>  >> http://www.catb.org/~esr/fetchmail/.
>
> Receiving fetchmail-6.2.0.tar.gz (1089936 bytes): 100% (ETA 00:00)
> 1089936 bytes transferred in 1050.8 seconds (1.01 kBps)
> ===>  Extracting for fetchmail-6.2.0
>
>  >> Checksum OK for fetchmail-6.2.0.tar.gz.
>
> ===>  Patching for fetchmail-6.2.0
> ===>  Applying FreeBSD patches for fetchmail-6.2.0
> ===>   fetchmail-6.2.0 depends on executable: gmake - not found
> ===>    Verifying install for gmake in /usr/ports/devel/gmake
> ===>   gmake-3.80 depends on shared library: intl.4 - not found
> ===>    Verifying install for intl.4 in /usr/ports/devel/gettext
> ===>   gettext-0.11.5_1 depends on executable: libtool - found
> ===>   gettext-0.11.5_1 depends on shared library: iconv.3 - found
> ===>   gettext-0.11.5_1 depends on shared library: expat.4 - found
> ===>  Configuring for gettext-0.11.5_1
> /bin/rm
> /usr/ports/devel/gettext/work/gettext-0.11.5/doc/gettext.info* rm:
> /usr/ports/devel/gettext/work/gettext-0.11.5/doc/gettext.info*: No
> such file or directory
> *** Error code 1
>

This is hard because gettext-0.11.5 is so old that it is most likely 
anything anyone tells you is going to take time. They updated gettext 
to 12.1 last August. The current version of gettext is 0.13.1 and that 
is a massive thing to move to. You don't stand a chance of getting 11.5 
fixed but some days you might be lucky. The current version of 
fetchmail is 6.2.5_1 and you will probably have the same problem with 
suggestions.

The interface to the gettext library has changed and you have to update 
everything that uses it. You may not be able to do it without upgrading 
to one of the current system releases. I would think that it is obvious 
that you haven't updated your port tree for some time. 

A normal solution would be to tell you to cvsup ports-all, rebuild the 
INDEXs, and try to rebuild. When I did that on an AMD 1600 XP running 
5.2-current, the rebuild of most of my ports was 1-2 days. My 2400 
running 4.9-stable used about 1/3 less time. Getting current on the 
ports could be only done with a great deal of thought. You might find 
11.5 as a package and install it. That would be a lot faster than 
bringing your port system to a current configuration.

If you do that, move to using portupgrade. It makes updating much 
easier.

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to