On Mon, Feb 16, 2004 at 02:10:11PM -0500, Marty Landman wrote:
> Any advice on what to do here?

> ===>  Configuring for gettext-0.11.5_1

That's an ancient version of gettext -- are you using a copy of the
ports tree you got from the installation CDs?  At a guess, you're
running FreeBSD 4.7...

Current version of gettext in ports is gettext-0.13.1 which provides
libintl.so.6 Come to think of it, fetchmail is now at version 6.2.5 in
ports so you must be using an old ports tree.  However so long as all
the sources are still available for download, you should be able to
install.

The problem appears to be due to this target in the devel/gettext port
Makefile:

    pre-configure:
        ${RM} ${WRKSRC}/doc/gettext.info*

which was removed with version 1.42 of the port Makefile -- you, I
suspect have version 1.38.  You could try just editing the Makefile to
change those lines to:

    pre-configure:
        -${RM} ${WRKSRC}/doc/gettext.info*

(ie. insert a '-' before the ${RM}) -- that will cause make to ignore
any error code produced by trying to remove some files that weren't
actually there in the first place.

        Cheers,

        Matthew

PS. If you're tempted to update your whole ports tree to the latest,
you should be aware that there have been some incompatible changes in
the pkg_foo tools which will cause you grief on a 4.7 system.  There's
a sysutils/pkg_install port you can install to help things out.  Most
things should work OK, but you'ld have to upgrade the system to a
supported version to be sure (ie. 4.9 or 5.2).

-- 
Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to