Sorry I can not help you with your problem.

An totally encrypted file system sounded very interesting,
I tried to find GBDE in the FBSD ports/package collection and
there is no hit on GBDE, or gbde, or encrypted FS.

Would you please provide the ports name or an URL to where I
can find out more about it?


-----Original Message-----
[mailto:[EMAIL PROTECTED] Behalf Of Dany
Sent: Monday, February 16, 2004 6:11 PM
Subject: GBDE - Destroy command not working

I've been playing around with GBDE under 5.2RC2-1. It's a fantastic
encrypted FS.
Following the man page, I've tried to use the destroy command but
without success.

Here is what I did to create the encrypted FS (for this test I
use the /dev/random to fill-up the disc).

# kldload geom_bde
# gbde init /dev/da0 -i
# gbde setkey /dev/da0 -n 2
# gbde attach /dev/da0
# newfs /dev/da0.bde
# mount /dev/da0.bde /mnt/usbkey
--> use the FS, works fine
# umount /mnt/usbkey
# gbde detach da0

Then according to the man page I should use  :
#gbde destroy da0 -n -1   to purge all keys but I get :
gbde: illegal option -- n

so I changed to :
#gbde destroy da0 --n -1   and got  :
gbde: read: Innapropriate ioctl for device

so I changed to :
#gbde destroy /dev/da0 --n -1  and this time I get the password
but it fails to destroy anything :
Enter passphrase:
Opened with key 0
gbde: No -L option and no space in sector 0 for lockfile

Maybe I didn't understand the purpose of the this command. I thought
was going to replace each lock key with some random data.
Can somebody explain me how to use the "destroy" command ?

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to