I've got 4-stable and can't get my USB CD-RW to read or write CDs. The CD-RW is connected to the computer via a USB 2.0 PCI card. I've got a ATA DVD-ROM that works perfectly fine.

When I boot, dmesg shows the USB CD-RW:

umass0: IOMEGA CDRW64892EXT3-B , rev 2.00/0.02, addr 2

All the USB-through-SCSI options are built into the kernel.

When I try to mount a CD in the drive, I get:

> sudo mount /cdrom
cd9660: /dev/cd0c: Invalid argument
dscheck(#cd/2): b_bcount 2048 is not on a sector boundary (ssize 385875968)

yet mounting the CD in the DVD-ROM (/cdrom1) drive works just fine.

Also, when running camcontrol:

> sudo camcontrol devlist -v
scbus0 on umass-sim0 bus 0:
<IOMEGA CDRW64892EXT3-B 6OP1>      at scbus0 target 0 lun 0 (pass0,cd0)
scbus-1 on xpt0 bus 0:
<  >                               at scbus-1 target -1 lun -1 (xpt0)

When trying to burn a CD with XCDroast the USB CD-RW is recognized on start-up. But when trying to write to the drive the green access light flashes every other second for a minute or so and then I get an error that no devices can be found. Incidentally, when I tried to install FreeBSD from this USB drive I was told that the CD looked like it was an audio CD. (The install went fine with the DVD-ROM.)

Any ideas? I've tried using 5.X, but when trying to burn a CD I get the "umass BBB bulk-in TIMEOUT" errors and the whole system freezes.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to